Go Down

Topic: Error while Programming- Help Us (Read 569 times) previous topic - next topic

May 14, 2011, 09:01 am Last Edit: May 14, 2011, 09:41 am by arjuntech1 Reason: 1
Hai
I am having trouble with progrramming my Arduino atmega168 serial.
when i am trying to program, it shows

avrdude: stk500_getsync(): not in sync: resp=0*00
avrdude: stk500_disable(): protocol error, expect=0*14, resp=0*51

what we have to do...???
we are in the middle of our project, wifi robot, and when our wifi router is connected to arduino, the receiver led glows permanently and no expected output is obtained..
please help us as soon as possible...
arjun_janan@yahoo.co.in

robtillaart

First thing todo is check under the tools menu if you have the right board selected
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

I can't tell from your description if you are saying you have the arduino serial board, or if you have an arduino clone connected via serial.

If it's not a "real" arduino board (i.e. RBBB or other breadboard type) you may need to use the reset button when uploading, or connect RTS from your serial port to reset on the arduino through a .1uF capacitor.

If it's the arduino serial board, you will need to use the Reset button, or you can do this hack to enable auto-reset http://arduino.cc/blog/2007/09/07/enabling-auto-reset-on-the-arduino-ng-and-serial-boards/
http://www.controllerprojects.com
My hobby controller projects site.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy