Go Down

Topic: probleme de reconnaissance de carte sd (bouclier Ethernet et arduino Mega) (Read 1 time) previous topic - next topic

wahib

Bonjour, a tous.

je viens d'avoir mon bouclier Ethernet, et voulais faire un teste d'enregistrement de données mais apparemment j'ai un probleme de reconnaissance de carte( je mets une carte sd mais il la reconnait pas).

merci pour vos conseils.

Gromain59

"pour résoudre un gros problème, il est souvent plus facile de le diviser en petits problèmes élémentaires..."

projet domotique xPLDuino
IRC: freenode #xplduino

wahib

bonjour je viens de cherché sur le net et je pense que mon bouclier n'est pas compatible avec Arduibo mega 2560

wahib


semageek

Salut,

Tiens regarde cette technique si tu as un problème avec le Shield Ethernet
(pour les version 1 et 2 sans connecteur ICSP)
http://mcukits.com/2009/04/06/arduino-ethernet-shield-mega-hack/

Mais c'est bizarre, depuis la v5, il y a une compatibilité avec les cartes Arduino MEGA,
via l'utilisation du connecteur ICSP pour la liaison SPI.
Retrouvez les kits Arduino dans notre boutique http://boutique.semageek.com/

Gromain59

Re

Je pense avoir eu le problème avec une Mega 1280. Ajoute dans ton setup():

Code: [Select]
// On the Ethernet Shield, CS is pin 4. It's set as an output by default.
// Note that even if it's not used as the CS pin, the hardware SS pin
// (10 on most Arduino boards, 53 on the Mega) must be left as an output
// or the SD library functions will not work.
pinMode(53, OUTPUT); //53 for MEGA, 10 for other arduino TODO check if no interference with ethernet


la pin 53 doit être déclarée en sortie (et pas utilisé bien sûr)

Gromain
"pour résoudre un gros problème, il est souvent plus facile de le diviser en petits problèmes élémentaires..."

projet domotique xPLDuino
IRC: freenode #xplduino

wahib

Merci pour vous tous, je viens de régler le problème avec le lien qui m'a passé "semageek"
http://mcukits.com/2009/04/06/arduino-ethernet-shield-mega-hack/
Merci

Gromain59

ok. Tant mieux si ce hack fonctionne. Mais je suis tout aussi étonné que semageek, car la version 5 résolvait ce problème.
Tu aurais une photo de ton shield ?

Gromain
"pour résoudre un gros problème, il est souvent plus facile de le diviser en petits problèmes élémentaires..."

projet domotique xPLDuino
IRC: freenode #xplduino

semageek

De plus, je viens de réfléchir, ce hack permet juste de déplacer la liaison SPI pour la partie Ethernet, il bouge également celle de la carte SD (car partagé) sauf la pin du Chip Select présent en PIN 4.
N'y aurait t'il pas un conflit entre les pin SS du W5100 et CS de la carte SD ? Genre les 2 actif en même temps.
Comme Gromain59, je serais curieux de voir le shield en photo.
Retrouvez les kits Arduino dans notre boutique http://boutique.semageek.com/

Go Up