Pages: [1]   Go Down
Author Topic: probleme de reconnaissance de carte sd (bouclier Ethernet et arduino Mega)  (Read 1292 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 0
Posts: 102
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour, a tous.

je viens d'avoir mon bouclier Ethernet, et voulais faire un teste d'enregistrement de données mais apparemment j'ai un probleme de reconnaissance de carte( je mets une carte sd mais il la reconnait pas).

merci pour vos conseils.
Logged

Pays de la betise
Offline Offline
Sr. Member
****
Karma: 4
Posts: 418
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut,

formate-la en FAT16.

Gromain
Logged

"pour résoudre un gros problème, il est souvent plus facile de le diviser en petits problèmes élémentaires..."

projet domotique xPLDuino
IRC: freenode #xplduino

Offline Offline
Full Member
***
Karma: 0
Posts: 102
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour je viens de cherché sur le net et je pense que mon bouclier n'est pas compatible avec Arduibo mega 2560
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 102
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

pour votre information j'ai la Version V6
Logged

Istres(13)
Offline Offline
Newbie
*
Karma: 0
Posts: 28
Hack the life !
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut,

Tiens regarde cette technique si tu as un problème avec le Shield Ethernet
(pour les version 1 et 2 sans connecteur ICSP)
http://mcukits.com/2009/04/06/arduino-ethernet-shield-mega-hack/

Mais c'est bizarre, depuis la v5, il y a une compatibilité avec les cartes Arduino MEGA,
via l'utilisation du connecteur ICSP pour la liaison SPI.
Logged

Retrouvez les kits Arduino dans notre boutique http://boutique.semageek.com/

Pays de la betise
Offline Offline
Sr. Member
****
Karma: 4
Posts: 418
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Re

Je pense avoir eu le problème avec une Mega 1280. Ajoute dans ton setup():

Code:
// On the Ethernet Shield, CS is pin 4. It's set as an output by default.
// Note that even if it's not used as the CS pin, the hardware SS pin
// (10 on most Arduino boards, 53 on the Mega) must be left as an output
// or the SD library functions will not work.
pinMode(53, OUTPUT); //53 for MEGA, 10 for other arduino TODO check if no interference with ethernet

la pin 53 doit être déclarée en sortie (et pas utilisé bien sûr)

Gromain
Logged

"pour résoudre un gros problème, il est souvent plus facile de le diviser en petits problèmes élémentaires..."

projet domotique xPLDuino
IRC: freenode #xplduino

Offline Offline
Full Member
***
Karma: 0
Posts: 102
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci pour vous tous, je viens de régler le problème avec le lien qui m'a passé "semageek"
http://mcukits.com/2009/04/06/arduino-ethernet-shield-mega-hack/
Merci
Logged

Pays de la betise
Offline Offline
Sr. Member
****
Karma: 4
Posts: 418
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

ok. Tant mieux si ce hack fonctionne. Mais je suis tout aussi étonné que semageek, car la version 5 résolvait ce problème.
Tu aurais une photo de ton shield ?

Gromain
Logged

"pour résoudre un gros problème, il est souvent plus facile de le diviser en petits problèmes élémentaires..."

projet domotique xPLDuino
IRC: freenode #xplduino

Istres(13)
Offline Offline
Newbie
*
Karma: 0
Posts: 28
Hack the life !
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

De plus, je viens de réfléchir, ce hack permet juste de déplacer la liaison SPI pour la partie Ethernet, il bouge également celle de la carte SD (car partagé) sauf la pin du Chip Select présent en PIN 4.
N'y aurait t'il pas un conflit entre les pin SS du W5100 et CS de la carte SD ? Genre les 2 actif en même temps.
Comme Gromain59, je serais curieux de voir le shield en photo.
Logged

Retrouvez les kits Arduino dans notre boutique http://boutique.semageek.com/

Pages: [1]   Go Up
Jump to: