Pages: [1]   Go Down
Author Topic: Arduino vanished from Device Manager  (Read 474 times)
0 Members and 1 Guest are viewing this topic.
Hampshire, UK
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Windows 7 64 bit, Arduino Uno

I'm a brand new newbie: Arduino arrived this morning.

Everything was working fine: plugged in Arduino, it appeared on Dev Manager, I installed the drivers, ran BLINK, changed the code, re-compiled, uploaded, all fine.

I had three COM ports, 2 and 3; Arduino was on 5.

Downloaded a new piece of code (http://ardx.org/CODE02), compiled, uploaded, all worked fine.

Changed code ... went to upload ... COM5 had vanished, and there's no sign of the Arduino in Device Manager.

I've tried resetting the Arduino (several seconds), unplugging, replugging, and I've restarted Windows.  Whatever I do ... no Arduino in Device Manager, no COM5 port, and upload does nothing.

But the Arduino is sitting on my desk, drawing power from the USB port, with 8 LEDs blinking on and off.

HELP!  Please ;o)

James Hardiman
Logged

Hampshire, UK
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I notice that this was reported on the old forum:

Arduino UNO Stops Working in 64-Bit OS's

The symptoms described there exactly match mine, but I can't see any solution there.
Logged

Hampshire, UK
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Aha!  Found the solution!

Because I'm using a desktop machine, and getting to the USB port involves getting on my hands and knees, I use a USB extension cable.

When I plugged the Arduino USB directly into the USB port on the desktop, the Arduino appeared again in Devmgr.

Funny that I didn't have that problem when I began.

Mystery.

James
Logged

Porto, Portugal
Offline Offline
Newbie
*
Karma: 1
Posts: 38
JoATMoN - Jack of All Trades, Master of None
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

USB cables have a length limit to work properly (about 5 meters), or even less for some types of communication. I'm guessing the first time you tried it it would work fine, but just because you got lucky smiley
Logged

Swannanoa, New Zealand
Offline Offline
Full Member
***
Karma: 1
Posts: 202
New To Arduino (and C)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Or possibly that the power pins are making contact, but not the two inner data pins.

At the speds the UNO uses, I doubt that its a 5m limit problem, more likely a physical cable issue.


mark
Logged

Pages: [1]   Go Up
Jump to: