Go Down

Topic: recurrent avrdude problem - protocol error, expect=0x14, resp=0x51 (Read 453 times) previous topic - next topic

stonechild


I'm getting the

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

error messages with an Arduino Duemilanove that I've been using for months without problem. I've read most of the threads about the problem and the trouble-shooting guide. Nothing that I've tried seems to have helped.

I was playing with as short sketch to get sound from an 8 ohm speaker. The sketch has pin 3 connected to an 100k ohm linear potentiometerr with the wiper connected to the red lead on the speaker and the black lead to the Arduino ground.  I was getting sound from the speaker for awhile and then the above problem started.

I can accept that in my electronic ignorance I may have fried the atmega328.  What I'd like to know is:  Is it likely that replacing the chip with the bootloader will fix the problem?

robtillaart

what was the resistance of the speaker? 8 ohm or ....?

With the potmeter completely to one side you got only the speaker between GND and the 5V => At 8 ohm  you got 5Volt/8 ohm ~= 625mA ==  bit too much.

Probably you need to replace the 328 chip with another one.

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy