Pages: [1]   Go Down
Author Topic: Library name problem  (Read 426 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 86
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I already have 2 libraries, compatible with arduino in source code, but their names are like this:

atmega-timers
atmega-scheduler

Arduino gave me an error saying that libraries can't contain signs and such. Why exists such a  limitation? I'm not using spaces or numbers.
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 642
Posts: 50366
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You need to post a screen shot of the library directory listing and the EXACT error message.

The - is a sign (like + or -). It may not be a valid character in a file name. Valid characters may be platform dependent, too, so mentioning what OS you are using would be useful.
« Last Edit: May 24, 2011, 08:39:52 am by PaulS » Logged

Central MN, USA
Offline Offline
Tesla Member
***
Karma: 75
Posts: 7264
Phi_prompt, phi_interfaces, phi-2 shields, phi-panels
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

When I was just starting my Arduino hobby I used to name file names like haha-01 but arduino ide changes it to haha_01, with the underscore. I suspect it comes from the fact that arduino ide is a hacked version of Processing ide, which also does this naming convention, possibly to avoid any problems across OS.
Logged


Pages: [1]   Go Up
Jump to: