Pages: [1]   Go Down
Author Topic: Arduino UNO upload delay  (Read 760 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I've been playing around with arduino Uno board. the only thing that's getting me down is upload times.
when upload button is clicked, the software waits for around 30-40 seconds (during which time nothing happens) and then uploads the sketch in couple of seconds (as shown inside IDE itself and flashing rx/tx leds on arduino board).

Is it possible to decrease(or remove) this initial delay as it's slowing the development down a great deal.

UPD: forgot to add that i'm running Windows7 and using 0022 version of Arduino IDE. there are only 2 com ports listed in tools menu.

Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Found a possible solution here:

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1285838328

points to Comodo firewall as the culprit for slow complication times.

preliminary results are positive, will do some proper testing later tonight.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

done some tests. while COMODO firewall does seem to have an effect, it's rather negligeble on my system.

Still looking for solution.

How long does compiling+uploading for everyone else? (i'm using a 46 line sketch)
Logged

Pages: [1]   Go Up
Jump to: