Go Down

Topic: rMp3 player problems SOLVED (Read 3049 times) previous topic - next topic


Jun 02, 2011, 11:58 pm Last Edit: Jun 07, 2011, 04:39 am by wthierry Reason: 1
I cant seem to find any support threads on rMp3 shields, other than the old read only forum... I am hoping someone can help me out... I seem to be able to communicate with rmp3, it can find the file names of my mp3s and output them in the serial monitor, so I assume communications is ok... but when I try to play them, I never hear any sound... I am usin plain old headphones to test it out, are amplified speakers required?  thanks in advance, and if a thead already exists on this, just point me to it...



plain old headphones should be fine - have you turned the volume up in the example?

Which example have you been using?


Ive tried about 3 or 4 examples from this thread:


So I do have communications, since I can see files, Is there any certain behavior the LED's should be doing while accessing the board?  Mine seems to blink a few times on start up, but then nothing. 


On startup a few blinks is normal.

When playing, the activity LED will be on/changing slightly if it's a VBR song.

If there are no lights then nothing is playing.

Try the RogueMP3 Playback example (included with the RogueMP3 library) and then report back if there is no sound when it's playing. The serial monitor will display 'playing' with a time etc.


it runs and continually prints out stopped: vol=16


so send 'p' and it should start playing

k is volume++ and i is volume--

The code should tell you the rest


I can increase and decrease the volume, but nothing ever plays...when I tell it to play, it still prints stopped.....


Well it should start playing if you have a song in the root directory called mysong.mp3

change this to your song:
Code: [Select]

#define SONG "/mysong.mp3"


thats why im confused.... nothing ever plays... I have the correct filename for the song, but nothing.....p doesnt toggle anything, like the function fails silently


Ok how is your SD card looking.

There should be a single .mp3 song in the root directory of the card (no folders), this should match the name of the song as defined in the top of the sketch. Make sure this song works on the computer.
I presume your SD card doesn't have weird formatting - how is it formatted?

Just loading stuff up myself to test.


yes. I have about 10 files in the sd card....none play, and they are in root....


sorry, it's not 'p' it's 'f' to start playing


Oh and my volume instructions were wrong...

i is volume up, k is volume down - I forgot it's reversed


I saw that when looking through the code.  But still no sound :(  really weird since I can use the SD library to obtain the filenames on the disk, but just not play them. 


Is it playing now? Activity light glowing?

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131