Go Down

Topic: Had it one day and already bricked it. Need to reset.... (Read 440 times) previous topic - next topic

tonyf84

I made a mistake that is letting the Arduino Mega take over the serial port and I can't upload anything to it now.  it's just looping and running the servo and trying to do Serial.println() with no delays.  How can I reset the Mega so that it has no code (like from factory). 

Thanks,

Anthony

johnwasser

1:  Unplug USB.
2: Press and hold Reset.
3: Plug in USB.
4: Click on the "Upload" icon for a sketch like "Blink".
5: When the "Binary sketch size:" message appears in the IDE, release the Reset buton

You may get away with 2, 4, and 5 alone but if your sketch is flooding the USB buffers you may need all five steps.
Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

tonyf84

Thanks!  That worked!  Needed all 5 steps, but it worked.   :smiley-mr-green:

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy