Go Down

Topic: Manchester encoding library for RF links. (Read 20 times) previous topic - next topic

tyke

Thank you carl47, that worked!
First I tried with Arduino 1.0 which did not work. Using 022 works flawlessly!

ciscoios

Hi Carl47,

I am using an ATtiny 85 (internal osc) for tx and an arduino with mega328 for rx. Using your examples all I get is 0s in the serial terminal. Any idea what I am doing wrong?

Thanks!

edimilsonramos

Hi Carl47,

I'm having the same problem Ciscoios.
What are we doing wrong?

Thank you.

carl47

When we get all 0's it could be anything.

My first guess would be hardware.

What rf devices are you using?

Do you have access to a CRO to see if data is going to the Tx or being received at the Rx.

Without lots more information I cannot be more explicit.

Cheers.

ciscoios

I have tried connecting a wire directly between RX and TX pins.. and a led for an indicator. TX transmits once a second. The RX (arduino) shows a 0 every second in the serial terminal. The output stops if I disconnect the wire.

I dont have a CRO.

Thanks !

Go Up