Go Down

Topic: problem with ethernet library since updating to 022 (Read 492 times) previous topic - next topic

gaggenau

hi im having problems with the ethernet library since the last arduino update.

everything compiles and therese no error messages but i cant connect to the ethernet shield. when im trying to ping it it says host is down no connection.

im using arduino duemilanove with atmega 328 and a ethernet shield with a wiznet 5100 chip on it.
and the latest version of the developing environment. (0022)

is there anyone that has a solution or have the sam problem as me.


PaulS

What version did you upgrade from? I don't think the change to the IDE makes any difference. Why did you upload new code to the functioning Arduino?

gaggenau

i upgraded from 0021.
mabye its not the upgrade thats the problem.

i was about to start a new project it didnt work so i loaded the web client example to the arduino and added

#include <SPI.h>

to the example and change the ip to the one i wanted to use
(192.168.2.6)

to se if it was something wrong with code i had written or something elese.

it did not work with the web client example either.
next I tried the web server example it did not work.
i cheked the status led on the shield and every thing looks ok.
the rx and tx leds flash sometimes.

next i tried another shield but with the same result.

then i tried another arduino board but it did not work either.

now im suspecting that it is something wrong with either the library or the ide.

i have used the ethernet library before with sucess but i cant rember wich version i have used.



Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy