Go Down

Topic:  Problem: Arduino & LCD with KS0066 / SPLC780 (Read 7 times) previous topic - next topic

floresta

#5
Dec 24, 2010, 12:04 am Last Edit: Dec 24, 2010, 12:08 am by floresta Reason: 1
Quote
Now I changed the wires so everybody will be able to follow them
Maybe everybody except me.  

I've had problems similar to this one where everything seemed to be connected properly using known good code and still the device didn't work.  I tracked it down to a poor connection on the solderless breadboard.  I suggest that you pull all the wires out and start again using a different part of the breadboard.  While you are at it you can reassign the pins, as Lady Ada did, so the LCD wires align nicely with the Arduino without having to cross over one another.

Don

kuhnikuehnast

#6
Dec 24, 2010, 12:32 am Last Edit: Dec 24, 2010, 01:06 am by 92888488 Reason: 1
So, to get a better view, i turned the breadboard 180° and wired everything again. Just changed the wireing in the code:

Code: [Select]
/*
 LiquidCrystal Library - Hello World

Demonstrates the use a 16x2 LCD display.  The LiquidCrystal
library works with all LCD displays that are compatible with the
Hitachi HD44780 driver. There are many of them out there, and you
can usually tell them by the 16-pin interface.

This sketch prints "Hello World!" to the LCD
and shows the time.

 The circuit:
* LCD RS pin to digital pin 12
* LCD Enable pin to digital pin 11
* LCD D4 pin to digital pin 5
* LCD D5 pin to digital pin 4
* LCD D6 pin to digital pin 3
* LCD D7 pin to digital pin 2
* 10K resistor:
* ends to +5V and ground
* wiper to LCD VO pin (pin 3)

Library originally added 18 Apr 2008
by David A. Mellis
library modified 5 Jul 2009
by Limor Fried (http://www.ladyada.net)
example added 9 Jul 2009
by Tom Igoe
modified 8 Feb 2010
by Tom Igoe

This example code is in the public domain.

http://www.arduino.cc/en/Tutorial/LiquidCrystal
*/

// include the library code:
#include <LiquidCrystal.h>

// initialize the library with the numbers of the interface pins
LiquidCrystal lcd(2, 3, 9, 10, 11, 12);

void setup() {
 // set up the LCD's number of columns and rows:
 lcd.begin(20, 4);
 // Print a message to the LCD.
 lcd.print("hello, world!");
 pinMode(13, OUTPUT);
}

void loop() {
 // set the cursor to column 0, line 1
 // (note: line 1 is the second row, since counting begins with 0):
 digitalWrite(13, HIGH);
 lcd.setCursor(0, 1);
 // print the number of seconds since reset:
 lcd.print(millis()/1000);
 delay(500);
 digitalWrite(13, LOW);
 delay(500);
 
}



Aaaand at last: A picture of the tidied wireing :D :

http://www.flickr.com/photos/kuhnikuehnst/5286800736/

and still nothin works...  :'( What else can I do to may fix it? I already asked the LCD wheter it will work as a christmas present, but it didn't wanted to... damn!

greetings kuhni

floresta

#7
Dec 24, 2010, 03:16 am Last Edit: Dec 24, 2010, 03:18 am by floresta Reason: 1
It's got to be something simple that we are overlooking.  I still suspect a bad connection between the Arduino and the LCD so now it's time to get out the magnifying glass and check the solder connections on the LCD pins.  Look for poor joints and for bridges (shorted pins).  

The reversed backlight connections that seem to work OK still bother me as well.

Also, you never commented on this (from reply #3)
Quote
I am assuming that you can vary the intensity of the blocks from very dark to very light


Can you measure the voltage between GND and pin 2 as well as between GND and pin 3?

Don

kuhnikuehnast

I already checked the soldering before I started programming the arduino. Pin 16 wasn't soldered that good, so I wired it again. I checked the other pins by using the "diode" test of my multimeter (one Pin to the soldered Pin, the other to the board. All pins are soldered well).

That's right! By using the Potentiometer, I kan vary the intensitiy of the blocks from very dark to very light. I read of some Problems if the contrast isn't adjusted properly. But I am able to adjust the contrast and tried already all "positions" :-)

The voltage of GND and Pin 2 is between 5,00V and 5,02V.

GND to Pin 3 is between 0V and 5V regulated by the Potentiometer. The "best legibility" is around 0,35V (the contrast isn't to high, and the blocks are already visible).

There are also no bridges between pins  :-/

Slowly I'm getting despaired!

What else can I try to fix this damn problem?


floresta

We are back to this "The reversed backlight connections that seem to work OK still bother me as well."

That type of display is almost, but not impossible, to view without the backlight.  Try disconnecting both backlight wires and see if you can discern anything on the display when you run your sketch.

Don

Go Up