Go Down

Topic: Problemi di funzionamento con il mio LCD 20x2 (Read 514 times) previous topic - next topic

Federico0

Ho da qualche giorno fatto i vari collegamenti del mio LCD 20x2 comprato non troppo tempo fa ma si accende solamente la retro illuminazione.. eppure.. non capisco, ho seguito alla lettera il datasheet e usato gli esempi della libreria liquidcrystal.h
Non si accendono nemmeno le cellete, che cosa può essere ? Unica mancanza è il potenziometro 10kohm ma ho messo una res da 10 k tra più e il pin adibito.. eppure.. sia con ch senza non si vede nulla!
Che cosa può essere ?!

Michele Menniti


Ho da qualche giorno fatto i vari collegamenti del mio LCD 20x2 comprato non troppo tempo fa ma si accende solamente la retro illuminazione.. eppure.. non capisco, ho seguito alla lettera il datasheet e usato gli esempi della libreria liquidcrystal.h
Non si accendono nemmeno le cellete, che cosa può essere ? Unica mancanza è il potenziometro 10kohm ma ho messo una res da 10 k tra più e il pin adibito.. eppure.. sia con ch senza non si vede nulla!
Che cosa può essere ?!

è proprio il contrasto il problema, e la R è sbagliata come collegamento. metti una 4,7K tra il pin del contrasto e GND, dovresti iniziare a vedere qualcosa ;)
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Federico0

Bene bene, oggi pome mi porto giù LCD e provo :) Grazie mille!

poi faccio sapere!

Go Up