Go Down

Topic: Radiocomando ed arduino (Read 2046 times) previous topic - next topic

lesto

vero, non ci avevo pensato :) però attenzione: resistenza in ingresso per essere certi che AL MASSIMO arrivino 5V all'arduino... quindi le prime misurazioni vanno fatte con il tester
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

sciorty

Ragazzi ho provato con un'altra ricevente a due canali. Siccome non ho tester non so quanto sia la tensione in uscita e quindi perora al posto che con 7.2 volt la alimento con 5v. Diciamo che funziona ma nell' "accelerata" noto cose strane: facendo la pulse in del pin ricevo dei valori che sono più o meno crescenti (160-200) ma se ad esempio mi fermo durante l'accelerata e poi riparto i valori colano a 0

lesto

senza sapre com'è fatto il circuito dubito che qualcuno possa darti una mano, salvo che esista qualhe "standard di fabbrica"
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

uwefed


vero, non ci avevo pensato :) però attenzione: resistenza in ingresso per essere certi che AL MASSIMO arrivino 5V all'arduino... quindi le prime misurazioni vanno fatte con il tester

Una resistenza limita la corrente ma non la tensione. Per limitare la tensione devi mettere un diodo zener da 4,7V tra entrata e massa e una resistenza da qualche decina di k Ohm tra entrata e uscita segnale del altro circuito.
Ciao Uwe

lesto

hai ragione, meglio però un partitore di tensione che da una lettura lineare anche se la tensione supera i 5V, però bisogna conoscere in anticipo la tensione massima
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

sciorty



vero, non ci avevo pensato :) però attenzione: resistenza in ingresso per essere certi che AL MASSIMO arrivino 5V all'arduino... quindi le prime misurazioni vanno fatte con il tester

Una resistenza limita la corrente ma non la tensione. Per limitare la tensione devi mettere un diodo zener da 4,7V tra entrata e massa e una resistenza da qualche decina di k Ohm tra entrata e uscita segnale del altro circuito.
Ciao Uwe


Ma secondo me il problema per il momento non è quello del voltaggio perchè anche se è alimentata a 5 v riesce a ricevere comunque. ma non mi spiego queste "colate", secondo voi sono legate al fatto del voltaggio ?

Go Up