Pages: [1]   Go Down
Author Topic: File Association??  (Read 1441 times)
0 Members and 1 Guest are viewing this topic.
Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 437
Posts: 23668
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I had -0018, -0019, now using -0021 (and have been for a while).
Windows Vista

Older sketches kept opening with -0019 when double clicked.
So I deleted the -0018 & -0019 folders.
Now I can't get the file associations for .pde to be with -0021.
How do I get that set up again?
When I open Windows Explorer, select one, choose Open With, Arduino does not appear in the list, and when I browse to it, I still can't get it to select it! So I have to start Arduino every time and then browse to the folder where the .pde is.

How do I fix this?

Thanks
Robert
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Australia
Offline Offline
Newbie
*
Karma: 1
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Right click on one of your files, choose the OPEN WITH menu option, then the CHOOSE DEFAULT PROGRAM menu option.

You might have to use the BROWSE button to find the directory in which you installed version 21, then find the ARDUINO.EXE file in that directory.
Logged

Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 437
Posts: 23668
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Exactly - and when I do that it acts as if I had selected cancel instead of ok, it drops back to the list of programs and does not open ardiuino-0021.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Hyderabad , India
Offline Offline
God Member
*****
Karma: 5
Posts: 621
can't help not to think arduinaizing something !
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

count me in i downloaded the 021 ide yesterday and am having the same problem  >smiley-sad
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 168
Posts: 12428
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


had a similar problem when upgrading from 19->21. I removed the old associations from the registry and then associated the .pde again.

// warning usage of regedit can cause serious damage to windows registry (on the other hand it is sometimes the only way)

Start regedit.exe

Check the following entries: - CTRL-F = find  .pde - use F3 to repeat search

Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.pde\OpenWithList

and

Computer\HKEY_USERS\ - some number - \Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.pde\OpenWithList

as -some number- might differ you should use seach.

I removed the entries here so windows "lost" all associations. When opening an .pde file windows will ask for the association, use browse to select Arduino21 and it worked as intended.













Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Hyderabad , India
Offline Offline
God Member
*****
Karma: 5
Posts: 621
can't help not to think arduinaizing something !
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

YES i had solved it just know and came back to post and i found the post was answered yesterday   >smiley-sad
« Last Edit: November 29, 2010, 11:54:13 am by newman » Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 168
Posts: 12428
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Don't be  >smiley-sad  be  smiley as you got the insight yourself  smiley-wink
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Rhode Island, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 16
What can't be done with an Arduino?
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I was having the same problem with Windows 7. I also found it necessary to remove some other registry entries including "arduino.exe." Sorry, I didn't make note of where the entries were, but I found then easily with a registry search.

[size=14]EASY FIX TIP:[/size] [size=12]If you don't want to be bothered making registry changes, you can work around the issue by renaming the new arduino.exe to something like arduino22.exe. Then you should be able to re-associate .pde files with the new version by the standard means (Right click file. -> Open with -> Choose default program...).[/size]

Logged

Leighton Buzzard, UK
Offline Offline
Edison Member
*
Karma: 20
Posts: 1318
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

"clever" windows sees the same program name so doesn't change the association properly!

you can try first setting the association to something else like notepad

then set it to the new arduino.exe
Logged

there are only 10 types of people
them that understands binary
and them that doesn't

Tilburg, Noord Brabant
Offline Offline
Newbie
*
Karma: 0
Posts: 46
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Exactly - and when I do that it acts as if I had selected cancel instead of ok, it drops back to the list of programs and does not open ardiuino-0021.

Same problem over here and 0021 is my first Arduino compiler installed.
Windows 7 Ultimate.

I'm opening sketches from the compiler now.
Logged

to baldly code what no man has coded before

Hyderabad , India
Offline Offline
God Member
*****
Karma: 5
Posts: 621
can't help not to think arduinaizing something !
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Don't be be as you got the insight yourself
Missed that post
Yeah good point  smiley but i'm lazy smiley-wink
Logged

Rhode Island, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 16
What can't be done with an Arduino?
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

mmcp42:
Quote
you can try first setting the association to something else like notepad then set it to the new arduino.exe

That was actually one of the first things I tried before searching the boards, it didn't work. I also tried renaming/moving/deleting the original arduino.exe that the .pde files where associated with so that windows would notice that it no longer existed, and would hopefully automatically disassociate it, but *icrosoft's "latest and greatest" operating system failed to release the broken association. Perhaps this problem would have been easier to correct if *icrosoft hadn't remove the file type manager that existed in their earlier OSs.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 19
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello all. For anybody that still wants this, I think I've got the quickest and most foolproof way to associate .pde files with Windows (at least XP).

1) First, open Windows explorer (i.e. My Documents).
2) Next, at the top toolbar (File, Edit, etc...) hover over Tools and select Folder Options.
3) In Folder Options, click the File Types tab and in the box, scroll down to extension pde. Click on it
4) In the lower half of the window, click the change button.
5) Then select the version of Arduino you want to be used click ok and close and you're done!
Logged

Rhode Island, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 16
What can't be done with an Arduino?
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

cubemike99, as far as I know you are correct, that is the quickest and most foolproof way for Windows XP. However, if I am not mistaken, that very File Types tab vanished with the release of Vista and 7. Why did *icrosoft remove it? The world may never know! [smiley=huh.gif]
Logged

Pages: [1]   Go Up
Jump to: