Go Down

Topic: Serial communication problem with Mega 2560 (Read 745 times) previous topic - next topic


Something has happened to my Arduino board (got it in march-april this year), which makes me unable to communicate with it via USB.
I can't upload sketches or update the firmware.

I've tried the all the regular stuff that's recommended in the forum to get it working.
The TX/RX leds never light up, not even when booting, but the 'L' led is always dimly lit.

I've tried it with Windows, OS X and Ubuntu, so it's not a OS specific problem.

This is what I get when I try to upload a sketch:
Code: [Select]

/usr/share/arduino/hardware/tools/avrdude -C/usr/share/arduino/hardware/tools/avrdude.conf -v -v -v -v -patmega2560 -cstk500v2 -P/dev/ttyACM0 -b115200 -D -Uflash:w:/tmp/build2222393668295502507.tmp/Blink.cpp.hex:i

avrdude: Version 5.10, compiled on Jun 29 2010 at 03:44:14
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/usr/share/arduino/hardware/tools/avrdude.conf"
         User configuration file is "/home/chris/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyACM0
         Using Programmer              : stk500v2
         Overriding Baud Rate          : 115200
avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_2_ReceiveMessage(): timeout

If I try to re-flash the board with dfu-programmer I get the following:
Code: [Select]

dfu-programmer at90usb82 erase
dfu-programmer: no device present.

Strange thing is that the board is recognized in Windows as Arduino Mega 2560, and in Linux the dmesg output is (in OS X I get a popup telling me a new network interface has been connected or something like that):
Code: [Select]

[64347.976064] usb 2-2: new full speed USB device using uhci_hcd and address 24
[64348.178966] cdc_acm 2-2:1.0: ttyACM0: USB ACM device


Can you post a link where you purchased the arduino please - are you sure it has a at90usb82 - it may have an ftdi chip - if you don't have a link then post a close up picture of the small chip close to the USB Chip.

http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly


I only have a pretty crappy iPhone camera, but the label on the chip below the USB port is:
1013       TH


Its the correct chip!!
Have a <b>CLOSE</b> look at the chip and surrounding components for missaligned components or dry looking solder joints.
If there is, fix that if you can.
But as its under a year old (assuming its official) 
Best to return it for exchange for a new one. If its a clone - Contact the supplier and see what they are willing to do.

http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131