Go Down

Topic: Installation errors on ubuntu 11.04 (Read 754 times) previous topic - next topic

KevinQ

I followed the instruction for installing arduino IDE for UNO in Ubuntu new version, http://arduino.cc/playground/Linux/Ubuntu. When I type the command : $ sudo dpkg -i *.deb
It gives the following errors:
(Reading database ... 262953 files and directories currently installed.)
Preparing to replace arduino 0022+dfsg-3 (using arduino_0022+dfsg-3_all.deb) ...
Unpacking replacement arduino ...
Preparing to replace arduino-core 0022+dfsg-3 (using arduino-core_0022+dfsg-3_all (1).deb) ...
Unpacking replacement arduino-core ...
dpkg: error processing librxtx-java_2.2pre2-8_ia64.deb (--install):
package architecture (ia64) does not match system (amd64)
dpkg: dependency problems prevent configuration of arduino:
arduino depends on libjna-java; however:
  Package libjna-java is not installed.
arduino depends on librxtx-java (>= 2.2pre2-3); however:
  Package librxtx-java is not installed.
dpkg: error processing arduino (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of arduino-core:
arduino-core depends on avrdude; however:
  Package avrdude is not installed.
dpkg: error processing arduino-core (--install):
dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_DK.utf8.cache...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for python-support ...
Errors were encountered while processing:
librxtx-java_2.2pre2-8_ia64.deb
arduino
arduino-core
Sorry, I am newbie in ubuntu.

MarkT

It seems you have downloaded an IA64 package....  You don't want that!  IA64 is the intel Itanium microprocessor, nothing to do with PCs, just get the i386 packages
[ I won't respond to messages, use the forum please ]

joop

actually, he needs an amd64 package of librxtx.  ;)

pluggy

With 11.04, you can just install the version (022) in the repositories via Synaptic package manager.  Earlier than 11.04 has an old version of Arduino(0018) in the repositories which has problems with later Arduino boards.
http://pluggy.is-a-geek.com/index.html

Go Up