Pages: [1]   Go Down
Author Topic: Power Problems when Driving a motor  (Read 459 times)
0 Members and 1 Guest are viewing this topic.
BRAZIL
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
II'm using a Uno board, and a DFRobot L298 shield, to power 2 Tamiya motors. I'm using a standard 9V battery, (6LR61), connected to Power in of DFRobot and Power of Uno Board. I can see Uno running, due to the leds on card, with expected behaviour. However, it does not activate the motors. The ground of both cards are connected, and when I connect the USB to Uno, it drives the motors. I measured the Vin of Arduino, which shows 4.8 ~4.9V. Any Idea about what is going on? It's my first Arduino project, so sorry if it's a stupid question. smiley-confuse
Thanks in advance,
Mauricio
Logged

0
Offline Offline
Faraday Member
**
Karma: 16
Posts: 2855
ruggedcircuits.com
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

A 9V battery is usually under-powered to drive motors. Try using a 7.2V AA battery pack, or a power supply, etc. Or just try 1 motor for now.

--
The Ruggeduino: compatible with Arduino UNO, 24V operation, all I/O's fused and protected
Logged

0
Offline Offline
Shannon Member
****
Karma: 207
Posts: 12194
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Alkaline PP3's are no good for high current work at all.  Don't try to take more than 50mA from them.

Possibly NiMH or lithium ones might work, but really if you driving motors and need 9V, you need a PP9 battery.
Logged

[ I won't respond to messages, use the forum please ]

BRAZIL
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for your support!
I tried two  independent power sources (with GND connected), and it worked. Besides, I realized the 9V battery  does not fit for this application as you stated. I`m gonna buy a NiMH battery for my project.
Logged

Pages: [1]   Go Up
Jump to: