Pages: [1]   Go Down
Author Topic: Arduino-Turns black when highlighting options?  (Read 941 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi everyone,

Would anyone be able to tell me how I could fix this problem?


arduinobug by aviatordom, on Flickr

Whenever I scroll down the menus it either goes completely black as in the image above or distorts in another way and "merges" with the other drop-down menus.

Disabling Aero in W7 and going to the Windows Classic theme didn't help. Running Arduino in compatibility mode for XP didn't solve this either.

Does anyone have any ideas?

Kind Regards,

Dominic
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 224
Posts: 13917
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

never seen such a screen (and hope to keep it that way )

Which version of Java VM are you running? have you upgraded it recently?
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I am running V6 update 26 of Java
Logged

North Yorkshire, UK
Offline Offline
Faraday Member
**
Karma: 104
Posts: 5531
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Update graphics drivers perhaps?

I have also never seen this.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Still no luck. Tried uninstalling and reinstalling Arduino (again). The problem hasn't gone away. Just to clarify, my Java is up to date, as well as my Graphics drivers. It is also evident when running a previous edition of Arduino (i tried 0022 and 0021).

I've even tried running Arduino as an Administrator in Windows XP compatibility mode (running Arduino on a W7 system), with the aero function disabled and it STILL happens.

Slightly off topic: I've noticed that games have been lagging recently, they never used to and I have a high end system. Could this be a graphics card related issue?  smiley-sad

If anyone could help me I would be very appreciative.
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17303
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I too was having very strange stuff displayed in the pull down arduino IDE menus, but only on version 22, not 21 or older versions, and it was kind of intermittent, not always repeatable. I had installed a replacement video card a few months ago, so I checked and found a newer driver for the board and after that update I haven't seen the same nonsense happen again. So maybe not your problem or solution but at least a similar symptom. Version 22 definitely does something different in it's video display interfacing.

Using windows XP SP3.

Lefty
 
Logged

North Yorkshire, UK
Offline Offline
Faraday Member
**
Karma: 104
Posts: 5531
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I also have some funny things happening with the menu text not appearing but it's not been a massive problem.

I presume it's just a java update which has some funny graphics issues.
Logged

Norfolk.UK
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try uninstalling Java completely. The Arduino editor comes with java runtime. I have the same probelm as you with win 7 64bit. Seems that Java messes with the my AMD windows graphics driver. My PC hangs and then recovers telling me the AMD grphics driver has recovered. Running with standard SVGA drivers cures the problem. So it seems like a driver/Java clash
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This happens to myself as well. Running the IDE v22 under Windows 7 64bit. However, I enabled compatibility mode for windows 2000 and checked run as administrator. That seemed to fix the problem... not sure why though.

somewhat comforting to find someone else who had/has the same problem. lol
Logged

Pages: [1]   Go Up
Jump to: