Go Down

Topic: Arduino Duemilanove Freezing Problem (Read 698 times) previous topic - next topic

DarkStarr

Hi

Another Newbie here, I have been having a problem for a while with my Arduino Duemilanove Freezing.

After uploading a sketch it works as it should but if I try to upload another sketch or reset the board I just get the avrdude sync error and the board will not run the uploaded sketch.

If I unplug the usb for a while (30mins ish) it runs the uploaded sketch ok and I am able to upload a new sketch and then the cycle repeats.

Im pretty sure its the Arduino Duemilanove as the problem remains if I switch it to a external power supply.

Is there anything that will discharge/reset after a period of time?

Thanks for help

Gary


joop

Try pushing the reset button just before you upload a sketch.

DarkStarr

Thanks joop, the reset doesn't appear to work at all.  After reseting the uploaded sketch does not work unless I unplug all power from the board for about 30min then everything works as it should

madworm


Hi

Another Newbie here, I have been having a problem for a while with my Arduino Duemilanove Freezing.


Please don't feel offended, but you provide almost no useful information, except the usual "it doesn't work". Unfortunately 'we' get to read that quite a lot here.

To make more than educated guesses, we need more information.

What arduino software version do yo use, what operating system, exact error messages (not quoted from memory), ... etc. etc. Please be as detailed as possible.

Please elaborate on the "30 minutes" issue. Did you test that time repeatedly, what about e.g. 5 minutes? Are you sure it is a timed issue and not just the unplugging/reinserting?
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

DarkStarr

Definitely not offended  :)

I was just trying to not post information that I thought would confuse the issue as I dont think its a software problem.  But if you think it will help Ill post the exact error messages and try to get a exact time for the error.

Thanks again

DarkStarr

Ok, ive tested this on XP, Win7 and OSX with the same results

The board only becomes unresponsive if the usb/power is disconnected (I was probably doing this so I could plug new wires in as I worked thought the tutorial) If I leave the board connected to the pc I can upload and reset ok.

Once I remove the usb/power the board will not work or accept new sketches for approx 12-15mins

This is the error I then get when trying to upload:  avrdude: stk500_recv(): programmer is not responding

Any Ideas?

madworm

OK, this should exclude any OS specific peculiarities.

Do the yellow RX/TX leds blink when you try to upload code in the non-functional period of time? And does the serial port (FTDI driver etc.) show up when uploads don't work? On MacOS there is (I think) some sort of device manager (explorer?). The serial port should be there.

If the serial port vanishes completely when the board plays dead and it is covered by warranty, I'd consider getting a replacement.
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

Go Up