Pages: [1]   Go Down
Author Topic: USB driver: Win7 + Studio 4 + UNO + Dragon = broke  (Read 574 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, Arduino world.

I'm developing a robot using a 2560 and four UNO's communicating over TWI.  The IDE that we use as beginners is fine for wee small projects, but soon enough I needed map files and debugging, so I'm trying to move to the Studio4 dev env.  Lately I've been having trouble with the USB drivers on windows7 and how they match up (or don't match up) to the Dragon, UNO, and 2560 under Studio4.

Interesting things I've learned: 
1 - update the firmware on the UNO's 8u2 USB controller using FLIP (from Atmel).  This overcomes some bugs with the IDE and USB comms.  I used Arduino-usbserial-UNO.hex and FLIP 3.4.3 after putting UNO into DFU mode.
2 - the windows USB driver that we install as part of the IDE installation works imperfectly with Studio 4 and prevents updating the bootstrap firmware using the IDE.  This driver is Jungo ver 10.1.1.0.
3 - if you update the USB driver using libusb-win32, you can then use the bootstrap-loading function of the IDE, but will no longer be able to use Studio 4 to connect with Dragon or UNO.

Can anyone out there suggest a USB driver for Windows7 that will:
  a - allow the Arduino IDE to comm w/ UNO and 2560
  b - allow Studio4 to comm w/ Dragon and UNO
  c - allow Studio4 to comm w/ AVRISP2 and UNO  (libusb-win32 kills both 'b' and 'c')
  d - will make change and wash my car. 

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Apparently this is an endemic problem and has some pretty shrill comms over it:

http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=86205&postdays=0&postorder=asc&start=20
Logged

Pages: [1]   Go Up
Jump to: