Go Down

Topic: Put a voltage where i should not have... (Read 791 times) previous topic - next topic

gruv2ths

Hell All,
Today i accidentally put +12 volts to pwm pin 11 on mt Arduino MEGA 2560.
Now it seems i cant program over USB.  The pin is labeled (OC1A/PCINT5)PB5 on the MEGA schematic.
The pin still functions normally as an output.

Any ideas??

Thanks in advance!!

CrossRoads

Don't use it as an input anymore? Be more careful next time?



Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

WizenedEE

I think he's trying to find out why the USB doesn't work, since that is unrelated to pin 11.

Also, how do you know the pin still functions as an output if you can't upload code? Or is that just what the current program does?

gruv2ths

Thanks WizenedEE, yeah i was not trying to be philosophical, i kinda need to fix this or move on. Ha Ha :-)

Yeah the pin seems unrelated to USB, and it is still running the test code that was programmed into it as i was screwing around with newly completed PWM driver board. The pin still outputs just fine.
Windows can see it and correctly labels it Arduino Mega 2650, so doesn't that mean some of the USB hardware is up and running??

Thanks everyone!!

gruv2ths

Speaking of the separate chip that handles USB comm. I notice that the TX led is not flashing. The test code that is running does sends serial.print statements almost all the time.

gruv2ths

Nothing was connected to pin1, but like mentioned above inside the chip anything could have happened. :-(

This is beginning to sound not fixable.. Does anyone have a drawing that gives you the reference designators?

Thanks for the help so far!

smeezekitty


I don't hold ANY hope that this is "fixable".  You have fried the Arduino chip. End of story.  If the Arduino chip were in a socket, you could pull it out and toss it and replace it with a new Arduino chip. But Mega 2560 is hard-wired.

The schematic diagram for Mega 2560 is here: http://arduino.cc/en/uploads/Main/arduino-mega2560-schematic.pdf

It is still "theoretically" fixable but it is surface mount with TONS of pins so you would have to have special surface mount equipment to fix it.
Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!

retrolefty

1. Does your PC recognize the board when you first plug it into your PC? If not the 8u2 USB serial converter chip is bad.

2. If it does recognize the board, then do the 'loop-back' test. If that fails you have a bad 8u2 chip.

3. If both those things work but still can't upload you have a bad 2650 chip most likely.

Lefty

Go Up