Pages: [1]   Go Down
Author Topic: cant upload codes from computer to arduino  (Read 475 times)
0 Members and 1 Guest are viewing this topic.
North Carolina
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just got my first arduino today, it is the mega 2560, it was a kit that came pre-loaded to to do random things on a 128x64 lcd display. I wanted to do something else though so i took everything off and made a 12 LED dimmer thing. After selecting the board and serial port from the tools menu in the programming software and verifying the code i uploaded it, everything seemed to be going okay 'till i got an error message:

avrdude: stk500v2_command () : unknown stus 0xc8
avrdude: initialization failed, rc=-1
               Double check connections and try again, or use -F to
overide
               This check.

avrdude: stk500v2_command () : unknown status 0x01
avrdude: stk500v2_disable () : failed to leave programming mode

I get that message no matter what code i try to use. i tried uploading it with the board unplugged and got the same message so it seems like it thinks theres a bad connection but the power comes on when it's plugged in.
Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 212
Posts: 13085
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Does this help?
http://forums.adafruit.com/viewtopic.php?p=91019#p91019

« Last Edit: October 23, 2011, 02:07:23 am by Coding Badly » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Same problem, with an Arduino 2560 ADK, Nothing attached and with The sample program Bling. Com3 is Regognized as an Arduino 2560 and said to be working fine (Windows Vista, Ide 022)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, so I solved it myself. After testing the board on an old XP it worked, reinstalling the drivers in Vista didn't work, but forcing (in vista systems) the board to go from Com:3 to Com:6 did the trick. Why???
Logged

Pages: [1]   Go Up
Jump to: