Go Down

Topic: Ayuda con LCDserial del Shield Módulos Conectar y Listo. (Read 1 time) previous topic - next topic

TINACHO

Jul 23, 2011, 12:24 am Last Edit: Jul 23, 2011, 10:04 am by TINACHO Reason: 1
Pues he comprado mi primera placa arduino UNO y este kit http://www.electan.com/catalog/arduino-shield-kit-modulos-conectar-listo-p-2987.html

La cuestión es que he ido probando cada uno de los módulos con los sketch que se muestran en la página del producto http://garden.seeedstudio.com/index.php?title=GROVE_-_Starter_Bundle_v1.1b, pero tengo problema con el módulo LCD

Este es el módulo


He descargado y descomprimido en la carpeta de librerias de arduino las librerias liquidcrystal, Newsoftlibrary y SerialLCD.
La cuestión es que no logro que me funcione el módulo lcd serial.   He probado varios sketch y corren sin dificultad en arduino, pero no logro que me funcione el módulo.   He notado que se encienden dos leds en el módulo, uno verde y otro rojo, no sé si esto da alguna indicación.

SrDonGato

al principio tuve problemas también para que funcionara, probé con otra librería y mano de santo.
con LCDCristal te funcionara sin problemas si es que tienes que conectar todos los pines , 4 de datos y 3 de control,
es posible que tengas una serial que se maneja de distinta forma, o que el LCD no se compatible con el standar que hay.

danos un poco mas de información

importante es también que en el subject hagas referencia al problema que tienes, los demás podremos buscar mas fácilmente  y lo que no sepan hallar la solución . cambia por favor el subject

TINACHO

Gracias por tu información y ya he modificado el asunto y he sido más específico... espero que me podais ayudar :)

TINACHO

Pues ya he encontrado la solución... resulta que estaba descargando una libreria erronea..  la libreria debe ser la siguiente.
SerialLCD_v1.0b_library

Gracias SrDonGato

Go Up