Pages: 1 ... 5 6 [7] 8 9   Go Down
Author Topic: Loop Back Test - Sticky?  (Read 33171 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, I did this procedure with my Arduino Mega board and nothing different happens. The problem is no usb communication and the two leds RX and TX still on (half power). Here is a little video to show you. Thank very much



Logged

Global Moderator
Boston area, metrowest
Offline Offline
Brattain Member
*****
Karma: 534
Posts: 26969
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You're not following the loopback test - I don't see Rx & Tx connected for instance.

So what happened leading up to this?   12V get applied to something it shouldn't have?
Sort of looks like a dead (or misprogrammed?) 16U2 device, it drives the Rx/Tx LEDs, and a good '2560, it drives the L LED. 
You could try to program both parts thru their ICSP connectors and see if they are still alive.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you for your answer. I did the connections from Rx/Tx and RESET to GND and nothing changes. The pc not recognize it when I connect it to USB (it was COM3)... my Arduino UNO works perfect with the same cable and same USB port (and all the time they worked in this USB port).
I was working with I2C communication between them with power supplies separated... I don't remember something suspicious.
I think ICSP is my only chance,( but I don't know what I need). Thank you and regards
Logged

Global Moderator
Boston area, metrowest
Offline Offline
Brattain Member
*****
Karma: 534
Posts: 26969
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Easiest way to program via ICSP is with Atmel AVR ISP MKii, $34 from mouser.com.
Driver can be found in an IDE folder.

You can also use the Uno as a programmer. Look at NickGammon's solution:
http://www.gammon.com.au/forum/?id=11635
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Montreal, Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What does it mean if the loopback test works without connecting RST to GND?
Like many other people, I have a board (Nano 3.0) which suddenly ceased to work.  When I first received it, it had no bootloader so I burnt one using a Mega2560 without any problems.  Over the course of a couple days, I used the Nano to test a Nokia LCD screen, some temperature sensors, and a few other things all problem-free... then one day, when I plugged it in to try something else, and it seemed have to lost it's bootloader.  I've tried to reburn the bootloader unsuccessfully several times, getting the same avrdude verification error which seems to indicate fried flash memory.
The loopback test works and everything sent gets echoed back, even when RST is not connected to GND, which gives me the impression the reset button is stuck on or shorted somehow... I've examined the board with a magnifier and do not see any shorts.
Anything else I should try?
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17293
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What does it mean if the loopback test works without connecting RST to GND?
Like many other people, I have a board (Nano 3.0) which suddenly ceased to work.  When I first received it, it had no bootloader so I burnt one using a Mega2560 without any problems.  Over the course of a couple days, I used the Nano to test a Nokia LCD screen, some temperature sensors, and a few other things all problem-free... then one day, when I plugged it in to try something else, and it seemed have to lost it's bootloader.  I've tried to reburn the bootloader unsuccessfully several times, getting the same avrdude verification error which seems to indicate fried flash memory.
The loopback test works and everything sent gets echoed back, even when RST is not connected to GND, which gives me the impression the reset button is stuck on or shorted somehow... I've examined the board with a magnifier and do not see any shorts.
Anything else I should try?


The reason for the reset to ground jumper is just insurance against if an existing program running in the AVR chip is utilizing pins 0 and 1 and could therefore cause problems with the loop back being hardwired between pins 0 and 1. The reset to ground causes the AVR to freeze and default all I/O pins to input mode so it can have no electrical effect on the pins 0 and 1 jumper installed for the test to operate. So the fact that the tests works OK even without the ground on reset, just means the USB serial converter chip is functional, and that is all it means.

Lefty
Logged

Spain
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have an Arduino Mega and it was working correctly until 1 day ago. I don't remember if I did a short or something but the problem is that now does not work. If checked Drivers, the usb laptop and the cable so I'm pretty sure is a board problem.

The problem is that when I connect the board to the USB there is no communication. I connect it and led "L" blink twice (so it is powered) and no more, TX and RX are like dead. I have tried to follow the "Loop-Back Test Instructions" and I don't know if I doing it correctly for Arduino Mega. (" http://arduino.cc/forum/index.php/topic,73748.0.html ")

In 3, "Connect Jumper from RESET to GROUND" is the same to maintain button reset pressed?.

And number 4, jumper from TX to RX, I have to do it in all of the Arduino Mega TX and RX's pins?

Thanks!
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 610
Posts: 49086
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
In 3, "Connect Jumper from RESET to GROUND" is the same to maintain button reset pressed?.
Yes.

Quote
And number 4, jumper from TX to RX, I have to do it in all of the Arduino Mega TX and RX's pins?
No. Only pins 0 and 1 are connected to the USB to serial converter, which is what the loopback test is testing.
Logged

Spain
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, so there is no detection in Windows, Mac or Linux. What should I do now? Is there a chip responsible of communication that I can change or is easier to change the board?

Thanks for the fast answer!
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 610
Posts: 49086
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Is there a chip responsible of communication
Yes. Right next to the USB connector.

Quote
that I can change
Depends on your ability with a soldering iron. It's a surface mount chip - beyond my skills to replace. (Software is so much easier.)

Quote
or is easier to change the board?
Sure. What the heck, it's only money.
Logged

Spain
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think I could change the chip but, is possible that I change it and it will still no working? I mean, if there was a short the atmel can also be damaged, isn't it?
Logged

Global Moderator
Online Online
Brattain Member
*****
Karma: 480
Posts: 18734
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

If you program it via the ISP interface (the 6 pins near the reset button) you may be able to keep using it, just without the USB interface (assuming that is what is wrong). You can do this with a $10 to $20 ISP programmer device, or just use another Arduino board as a programmer (look up Arduino as ISP).
Logged


Global Moderator
Online Online
Brattain Member
*****
Karma: 480
Posts: 18734
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

If you have a Uno or similar lying around you can use my "chip detector" sketch to see if the main processor is OK:

http://www.gammon.com.au/forum/?id=11633

Example hook-up:



You don't have to use the special cable, you can use jumper wires to the correct pins.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset



MY UNO WAS WORKING GREAT .. BUT
SUDDENLY IT IS NOT RECOGNIZED BY MY PC...
I M HAVING TROUBLE WITH MY UNO R3. PC NOT DETECTS IT , I.E "NO DEVICE FOUND PROBLEM"
I CHANGED MY CABLE , TRIED ON OTHER PC BUT NO COMPORT , OR NO "NEW DEVICE FOUND"
WHAT IS THE PROBLEM ?

 I HAVE DONE "Loop-Back Test"
! BUT GOD KNOWS WHY NO DEVICE DETECTED IN PC ....... HELP ME GUYS'


ADVANCE THANKS !
Logged

Washington
Offline Offline
God Member
*****
Karma: 38
Posts: 790
Firefox & Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset



MY UNO WAS WORKING GREAT .. BUT
SUDDENLY IT IS NOT RECOGNIZED BY MY PC...
I M HAVING TROUBLE WITH MY UNO R3. PC NOT DETECTS IT , I.E "NO DEVICE FOUND PROBLEM"
I CHANGED MY CABLE , TRIED ON OTHER PC BUT NO COMPORT , OR NO "NEW DEVICE FOUND"
WHAT IS THE PROBLEM ?

 I HAVE DONE "Loop-Back Test"
! BUT GOD KNOWS WHY NO DEVICE DETECTED IN PC ....... HELP ME GUYS'


ADVANCE THANKS !
Pretty much the causes are fried or misprogrammed USB interface chip.
Logged

Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!

Pages: 1 ... 5 6 [7] 8 9   Go Up
Jump to: