Pages: 1 [2]   Go Down
Author Topic: Problemas con motor Brushless  (Read 3019 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

puedes probar como se inicializan y demas con el receptor de radio y los esc, prueba a conectarlo de las diferentes maneras posiciones de sticks y demas y veras como funciona.

un saludo

Con la radio también me funciona perfectamente. Algo tiene/hace el receptor que no soy capaz de reproducir en el Netduino.
Logged

Ciudad Real
Offline Offline
God Member
*****
Karma: 1
Posts: 747
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

prueba esto.

Code:
#include <Servo.h>
 
Servo myservo; 
 

int PinESC = 9;
 
void setup()
{
  myservo.attach(PinESC);  // attaches the servo on pin 9 to the servo object
  myservo.write(0); // ponemos la potencia a 0
  delay(5000); // espera a que se inicialice el esc
}
 
void loop()
{
  myservo.write(128); // ponemos la potencia al 50%
  delay(5000); // durante 5 segundos
    myservo.write(128); // ponemos la potencia al 25%
  delay(5000); // durante 5 segundos
    myservo.write(255); // ponemos la potencia al 100%
  delay(2000); // durante 2 segundos
    myservo.write(0); // ponemos la potencia al 0%
  delay(10000); // durante 10 segundos
 
 
 
}

cambia PinESC a donde tengas cogida la señal PWM al ESC

ya nos cuentas
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Es que el código que he puesto hace lo mismo.....
Logged

Ciudad Real
Offline Offline
God Member
*****
Karma: 1
Posts: 747
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

más no te puedo ayudar ... sé que a mi me funciona como te estoy diciendo. quizas los esc son distintos , no lo se
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

más no te puedo ayudar ... sé que a mi me funciona como te estoy diciendo. quizas los esc son distintos , no lo se


No creas que te lo he dicho a mala eh, al contrario, te agradezco que intentes ayudarme.

Es que creo que el tema es ese, que son distintos.

Sobre el tema de usar un relé o Tiristor.... me podrías orientar un poco?? No se muy bien como saber que especificaciones tendría que tener para que aguantase la potencia de 4 motores.
Logged

Ciudad Real
Offline Offline
God Member
*****
Karma: 1
Posts: 747
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

los picos de correinte que consumen los ESC son muy altos, necesitas reles tochos.

valora el peso que va a tener el quadcopter, cuantas mas cosas le pongas mas pesa.

buscate el esquema del relay-shield para ver como se conecta un relé al arduino.

un saludo
Logged

Barcelona, Catalunya, España, la Tierra, Sistema Solar, Brazo de Orión, Vía láctea, Grupo local
Offline Offline
Jr. Member
**
Karma: 0
Posts: 71
"The best way to predict the future is to implement it." Alan Kay
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


Lo que ocurre es que usais ESC distintos. Yo tengo unos como los que dice Vallekano y está en lo cierto, no hay más solución que conectarlos después. Es algo bastante típico entre algunos ESC, no me preguntes porqué, pero te exigen que el receptor ya esté en marcha cuando arranca el ESC. Lo del relé... no te lo recomiendo, piensa que todo el corriente del motor (y del ESC) tendrá que pasar por el relé, y eso si pones uno por motor/ESC. No sé como son tus motores, pero yo tengo ESC de 30A puestos, así que un relé que lo soporte tiene el tamaño de un camión cisterna smiley-lol.

Yo había pensado hacerlo con transistores, que suele ser más eficiente y fiable, pero se calentarían una barbaridad y perdería mucha potencia a lo tonto. Ponte un conector comodo con el que puedas conectar primero uno y luego el otro, que tampoco es para tanto.

 
No vale la pena destrozar tanto el rendimiento de tu QR solo por una chorrada como esa.


PS: Pon fotos!!! (ya pondré yo las mias smiley-grin)
Logged

Ciudad Real
Offline Offline
God Member
*****
Karma: 1
Posts: 747
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sale más barato comprar otros ESCs que los reles tochos smiley-grin

yo mi wiicoptr aun no acabo de apañarlo bien
los motores tienen demasiada potencia i los sensores de la wii no funcionan bién juntos. son todo mas que problemas smiley-grin
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas de nuevo.

Pues tras retomar el tema y hacer mil pruebas resulta que funciona todo bien una vez montado y funcionando con la batería.

El problema solo se me reproduce cuando tengo el Netduino conectado por USB al PC.

Bueno, sea como sea ya funciona así que guay.


Peeeeeeeeeeeeero, ahora tengo otro problema, jeje.


Tras conectar todo y empezar a hacer pruebas resulta que me pasa lo siguiente:
Los 4 motores funcionan perfectamente y responden a los mandos de la emisora son problemas. Pero cuando paso de un 70%+- de potencia hay uno que se para. Si vuelvo a bajar la palanca hasta abajo y vuelvo a dar potencia vuelve a funcionar. Así hasta que vuelvo a darles caña, que hay uno que se para.

He probado a cambiar motores y ESC y el "problema" es un ESC. El motor que esté conectado a él es el que se para.

Pero lo raro de todo es que si en vez de los 4 motores solo tengo conectados 2, puedo darle potencia al 100% que va perfecto. Al meter un tercer motor, en cuanto llego al 70%-80% de la potencia, el motor que esté conectado al ESC problemático se para.

En principio parece que el ESC está jodido, pero me mosquea mucho que si solo conecto 2 funciona perfectamente. Será algo de la batería???

Logged

Ciudad Real
Offline Offline
God Member
*****
Karma: 1
Posts: 747
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hay otra configuraciopn que le puedes cambiar. lo que pierde es sincronismo y por eso se para.

le habras puesto una frecuencia demasiado alta o una configuracion para motores mas potentes, tambien me pasó a mi.

un saludo
Logged

Barcelona, Catalunya, España, la Tierra, Sistema Solar, Brazo de Orión, Vía láctea, Grupo local
Offline Offline
Jr. Member
**
Karma: 0
Posts: 71
"The best way to predict the future is to implement it." Alan Kay
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset



Ahora que veo el post, el otro día probé a conectar la alimentación que generan los propios ESC (si tienen BEC). Resulta que así si funciona, a saber porqué. Debe emplear un delay automático respecto a esa alimentación en concreto o algo así, que le permite funcionar correctamente. Lo digo porque si sigues con eso, puede que esto te quite algun que otro dolor de cabeza smiley-wink
Logged

Pages: 1 [2]   Go Up
Jump to: