Pages: 1 [2]   Go Down
Author Topic: Unable to upload programs to an Arduino Mega2560  (Read 3672 times)
0 Members and 1 Guest are viewing this topic.
Durango, Colorado, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 21
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have looked at a lot of posts, but don't see an image or description of where the location of the pin to short to ground is.  It looks like the group of 6 pins near the usb port is the same as on the UNO, but I can't figure out where the two pins in the UNO illustration are on the MEGA.

Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It's the two pads near the 6-pins (for the 8U2) on the back of the Mega 2560.
Logged

Durango, Colorado, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 21
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks - even the Arduino official site says that the solder pads are next to the map of Italy silkscreened on the back of the board.  I really appreciate your clear and concise tutorial.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I'm totally new to Arduino (received this morning the UNO) and I have very few experience with microcontrollers. Here is my experience with the serial issue discussed in this post, in the end my question.

I have an ubuntu 9.10, Arduino UNO, arduino0022 (32bit even if my pc is 64 bit; I guess a Java compatibility issue without consequences for this post).

After 5 minutes of unpackaging I was able to run the blinking led example so I tried the "AnalogReadSerial" and got my board stacked with the TX led always on.

I (eventually) updated the firmware as described in several posts but the problems was still there.

I solved by connecting the board to a Windows PC and uploading a different sketch. I unlocked the /dev/ATM0 serial port on my Linux PC and then it worked again.

I do not know why but I'm not sure I correctly upgraded the firmware.

Now the question, how can I prompt the board to verify the uploaded firmware?

In case the firmware is not upgraded what is exactly the command to avoid until I upgrade the firmware correctly?

thanks in advance,
g.

Logged

Offline Offline
God Member
*****
Karma: 32
Posts: 507
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Unfortunately dfu-programmer doesn't seem to have a verify mode.

Enter the following in a terminal:

sudo lsusb -v -d 2341: | grep bcdDevice

The old firmware is 0.00, the new one is 0.01. If you get 0.00 you need to update the firmware again.

(This might be wrong though, maybe someone else can confirm it is right)
Logged


brooklyn
Offline Offline
Newbie
*
Karma: 0
Posts: 38
transpersonal
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I've never done anything with a terminal before...Trying to update this firmware. I've got to the point of resetting the 8u2, and have the terminal open to the right directory, but when I type in

sudo dfu-programmer at90usb82 erase

to the terminal, it either says

sudo: dfu-programmer: command not found

or asks me for a password. there is no password set on my computer for installing things.

any advice? thanks, i'd appreciate it. it's taken me all night to get to this point.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had the same problem with UNO, suspecting serial flood communication going from arduino. Solution was push and hold reset button on arduino, click on Upload, wait 1-2 secs and release reset button, sketch was then successfully uploaded without notification about used port.
Logged

Vancouver, Canada
Offline Offline
Jr. Member
**
Karma: 0
Posts: 73
I want to make a living designing robots
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Techie, I'm in the same boat as you.  I get one upload per cold boot.  Eagerly awaiting a step by step tutorial because I'm not so great with electronics (yet).

Windows 7
Arduino022
Mega2560

Tried with atmega1280, same result.
« Last Edit: August 08, 2011, 10:00:32 pm by aggrav8d » Logged

Pages: 1 [2]   Go Up
Jump to: