Go Down

Topic: problem with scketch upload (Read 578 times) previous topic - next topic


core.a(main_orig.cpp.o): In function `main':
/home/insippo/arduino-0022/hardware/arduino/cores/arduino/main_orig.cpp:7: undefined reference to `setup'
/home/insippo/arduino-0022/hardware/arduino/cores/arduino/main_orig.cpp:10: undefined reference to `loop'

ubuntu 10.04, arduino duemilanove and eth shield w5100 with sd card. If i connect eth shield to arduino usb connection filed.
if i upload without eth shield : core.a(main_orig.cpp.o): In function `main':
/home/insippo/arduino-0022/hardware/arduino/cores/arduino/main_orig.cpp:7: undefined reference to `setup'
/home/insippo/arduino-0022/hardware/arduino/cores/arduino/main_orig.cpp:10: undefined reference to `loop'  again this error
what the problem ?



Does the sketch contain  setup() and loop() function definitions?  This error suggests the compiler can't find them.
[ I will NOT respond to personal messages, I WILL delete them, use the forum please ]


Aug 03, 2011, 06:46 pm Last Edit: Aug 03, 2011, 06:49 pm by insippo Reason: 1
if i connect w5100 shield to arduino, arduino disconnect from usb port and arduino ide says:
Error inside Serial.serialEvent()
java.io.IOException: Input/output error in nativeavailable
   at gnu.io.RXTXPort.nativeavailable(Native Method)
   at gnu.io.RXTXPort$SerialInputStream.available(RXTXPort.java:1532)
   at processing.app.Serial.serialEvent(Serial.java:215)
   at gnu.io.RXTXPort.sendEvent(RXTXPort.java:732)
   at gnu.io.RXTXPort.eventLoop(Native Method)
   at gnu.io.RXTXPort$MonitorThread.run(RXTXPort.java:1575)
ubuntu 10.04 and ubuntu 10.10 arduino duemilanove+w5100 with sd card reader

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131