Go Down

Topic: 7805 e condensatori (Read 2973 times) previous topic - next topic

alimento in breadbord un atmega con un 7805: i condensatori perchè devono essere più grandi in entrata che in uscita??
se non rispetto questa regola l'atmega ha dei problemi in avvio: non carica e altro.
ma se imposto l'oscillatore interno nessun problema.

da cosa deriva questo strano comportamento? e perchè non va bene con i condensatori così?

Federico Vanzati

ehm...così come!?!?

comunque in ingresso di solito li metti più grandi perchè ti fanno da filtro per le eventuali grosse oscillazioni dovute all'alimentazione in ingresso non stabilizzata.....come il condensatore che metteresti in parallelo dopo al ponte di diodi a valle di un trasformatore....se metti un condensatore diminuisci il ripple della tensione in ingresso.
F

Federico

Non mi risulta questa cosa... Io con uno schema come questo
e due cap elettrolici identici prima e dopo, sono sempre andato bene. Ho visto su googleImmagini che ci sono schemi che utilizzano cap nel mondo che indichi tu, ma non ti saprei dire come mai.
F
Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

83darking83

#3
Feb 19, 2011, 01:18 pm Last Edit: Feb 19, 2011, 01:22 pm by 83darking83 Reason: 1
Nel datasheet del 7805 consigliano semplicemente di mettere un condensatore da 330 nF in ingresso e uno da 100 nF in uscita:




obnubilated

Possibile che il condensatore da 0.33 sia per filtrare e quello da 0.1 unicamente per filtrare la componente continua?

scusate è vero non ho specificato che ho in uscita uno da 1000microF e in entrata uno da 100microF

si quello grande in ingresso serve a mantenere stabile la corrente in entrata.
io però necessito di grande capacità dopo... mentre prima meno.

e fin li ok non funzionasse sempre direi che è colpa del circuito ma se imposto l'oscillatore interno smette di far casini in avvio e non salta un colpo!
invece se metto l'oscillatore esterno alè una volta si avvia 2 no.


pricoso


Nel datasheet del 7805 consigliano semplicemente di mettere un condensatore da 330 nF in ingresso e uno da 100 nF in uscita:






Salve ragazzi,
ho un alimentatore con uscita a 12V per  alimentare Arduino. Vorrei seguire questo schema con il 7805, ma ho dei condensatori poliestere da 100nF e 330nF, vanno bene? O servono elettrolitici?

ratto93

Vanno bene comunque....E poi... nello schema non sono indicati condensatori elettrolitici polarizzati ma normali condensatori (ceramici, mkp, poliestere etc...)
Se corri veloce come un fulmine, ti schianterai come un tuono.

flz47655


Possibile che il condensatore da 0.33 sia per filtrare e quello da 0.1 unicamente per filtrare la componente continua?


Nessuno filtra la componente continua, sono collegati in parallelo non in serie


Quote
scusate è vero non ho specificato che ho in uscita uno da 1000microF e in entrata uno da 100microF

si quello grande in ingresso serve a mantenere stabile la corrente in entrata.
io però necessito di grande capacità dopo... mentre prima meno.


In uscita da 1000uF è troppo! Più un condensatore è grosso più è "lento" a rispondere alle variazioni di tensione, quindi filtra frequenze più basse.

Se usi condensatori così grossi ti serve un diodo per non rompere il regolatore allo spegnimento

Perché ti serve grosso dopo?

Ciao

flz47655


se non rispetto questa regola l'atmega ha dei problemi in avvio: non carica e altro.


Se metti condensatori troppo grossi la tensione all'avvio sale lentamente e potrebbe intervenire il Brown-out del micro che lo resetta se la tensione non è ad un certo minimo impostato tramite i fuses

Ciao

leo72

@garinus:
i tempi di avvio del microcontrollore sono controllati dai valori di fuse. Se imposti dei valori molto brevi, potresti avere problemi di stabilità all'avvio. Il problema si potrebbe presentare maggiormente con clock elevati, forse è questo il motivo per cui con l'oscillatore interno non si manifesta. Che valori dei fuse hai impostato sul micro?

Go Up