Go Down

Topic: Arduino 0013 released. (Read 5590 times) previous topic - next topic

TinMan

I also get the error message Phil mentioned. However, I just purchased my Arduino and really dont have any programming experience. I am stumped when it comes to updating Java's .jnilib

If there is any easy way to do this could someone point me in the correct direction? I would like to get my arduino working as soon as possible!

Best regards,
tinman

DOZ

I installed the lib per instructions.
I am getting

Uncaught exception in main method: java.lang.UnsatisfiedLinkError: /Applications/ARDUINO/arduino-0011/Arduino 11.app/Contents/Resources/Java/librxtxSerial.jnilib:

with both 11 and 13.  (IMac, Leopard 10.5)

How about some accurate complete information we can use to fix this problem.  ANYONE?

Previous posts assume newbies know more than do about Mac internals

mellis

I think you may have problems on Leopard if you have your default Java version set to 1.6.  Try running /Applications/Utilities/Java/Java Preferences.app.  Check the order of the Java application versions.  I have J2SE 5.0 on top.  If you don't, try moving it to the top (this should be the default).  Then try running Arduino.

If that doesn't work, trying right-clicking on Arduino.app and select "Show Package Contents".  Edit Contents/Info.plist (with TextEdit) and change the JVMVersion from 1.4+ to 1.5*

follower

Thanks for the suggestions mellis, I thought I'd try them out with the original file.

Quote
I think you may have problems on Leopard if you have your default Java version set to 1.6.

That's the explanation I've seen but I think there might be something different at play here.

Quote
Try running /Applications/Utilities/Java/Java Preferences.app.  Check the order of the Java application versions.  I have J2SE 5.0 on top.

My Java Preferences look like this--when it doesn't work:



Quote
If that doesn't work, trying right-clicking on Arduino.app and select "Show Package Contents".  Edit Contents/Info.plist (with TextEdit) and change the JVMVersion from 1.4+ to 1.5*

Even with this, it still fails to work with the original library:

Code: [Select]

           <key>JVMVersion</key>
           <string>1.5*</string>


Odd. Exactly what version(s) of Mac OS X have you seen working?

--Phil.

mellis

At least 10.5.6.  Do you know what the cause of the error you see is?

follower

I am using 10.5.2 I had thought I'd read something about 64- vs 32- bit versions of the library but that might be getting confused with the linux issue.

I updated my solution documented on the above link to include details on how to download the file into the correct place via the terminal.
Code: [Select]

curl -o ~/Applications/arduino-0013/Arduino\ 13.app/Contents/Resources/Java/librxtxSerial.jnilib http://iharder.sourceforge.net/current/java/librxtxSerial.jnilib


I'd appreciate it if people could try that because documenting how to save it graphically into the correct place will take multiple steps--and I just wasted a stupid amount of time fighting with curl and spaces in file paths for reasons I don't understand. :-/

--Phil.

jerrya.net

0013 runs on my 10.5.6 without having to do anything special. I downloaded it and it ran the first time I tried to launch it.
- Jerry Adlersfluegel

follower

BTW has anyone tried the above fix I posted? I've just realised that I think I might not have tested it with USB serial uploading. When I try to do that I get:

Code: [Select]
Serial port '/dev/tty.usbserial-.....' already in use.

Restarting the IDE doesn't work. Using 0012 still works. lsof doesn't seem to show anything.

--Phil.

timmo

After a first time installation on Mac Os X 10.5.6 I have the same linker problem:

Uncaught exception in main method: java.lang.UnsatisfiedLinkError: /Applications/ARDUINO/arduino-0011/Arduino 11.app/Contents/Resources/Java/librxtxSerial.jnilib:


Any change of java versions (1.5/1.6 & 32/64 bit) has no effect.
Any ideas?

follower

I discovered that in order to get the above "fix" with the downloaded library to enable upload in the IDE via USB successfully I needed to also do the following in the terminal:

Code: [Select]
sudo mkdir /var/lock
sudo chmod 777 /var/lock

I don't know what security implications this has, if any.

--Phil.


unxzst

did you guys get it to work?
i'm on dual core intel 64 jaunty, and for some reason i have 0010.  avrdude says programmer not responding thoug rt&tx blink, i tried resetting it.
i'm a complete newbie and am now trying to compile avrdude-5.4-arduino-src i found in the main page, and have 5.5-7 installed with synaptic.

Go Up