Go Down

Topic: Arduino 0013 released. (Read 5431 times) previous topic - next topic

Beardy241

FYI...  I just pulled the v13 zip from Google (few times) and it won't unzip.  Crashes Expander every time.

Pulled the zip from arduino.cc and it worked fine.

hth

[m]

jeroavf

Hi ,
The referece pages in the linux tarball are obsolete, it does not include the new functions and types ( word, word(), bitRead(), bitWrite(), bitSet(), bitClear(), bit(),  lowByte(), and highByte() ) .
Sorte = Preparo + Oportunidade

http://www.blogdoje.com.br
Avr, Arduino, AVR32, Renesas , ARM e tecnologia em geral

bill2009

I guess

"* Adding support for printing floats to Print class (meaning that it works
in the Serial, Ethernet, and LiquidCrystal classes too).  Includes two
decimal places."

means something different than I thought since Serial.print(<some float>); still gives an error.  What DOES it mean?


bHogan

#18
Feb 24, 2009, 02:03 am Last Edit: Feb 24, 2009, 02:45 am by BroHogan Reason: 1
It shouldn't give an error. Serial.print(<some float>) works for me in REL 0013  :-?
What kind of error?
"Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom."
~ Clifford Stoll

bill2009

woohoo thank you.  I still had 010 pinned to my start menu!

halley

Just in case it's not obvious, Serial.print(<some float>); wasn't literal.  The <some float> part meant a variable or number of type float or double.  Something to be printed with a decimal point.

RIDDICK

hey!

when can i upgrade my 0012-linux-amd64 package to 0013?

bye
-Arne

mellis

As soon as someone builds a version of Arduino 0013 for 64-bit Linux.  Any volunteers?

westfw

I'm curious.  Don't 32bit binaries usually run on 64bit linux?  What's the point in a 64bit Arduino binary?  "amd64" means compiled for the AMD64 ABI, not specifically for an AMD cpu, right?

madworm

I thought the java code used for serial I/O was the problem ?
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

follower

I was finally in a position to test this release on a machine with Mac OS X 10.5.2 and it failed to start, instead it generated the following error:

Code: [Select]
java.lang.UnsatisfiedLinkError

The error went away when I replaced the shipped version of librxtxSerial.jnilib with the librxtxSerial.jnilib version here.

Version 0012 runs fine on the same machine so I wonder if an (unintended?) configuration change in the build has resulted in the problem.

More details on fixing the gnu.io.RXTXCommDriver UnsatisfiedLinkError error here.

--Phil.

RIDDICK

i think, the amd64 version would use the normal libraries and java-amd64?

but the 32-bit version would need a lot of fumbling... :-)

e. g.: lib/librxtxSerial.so

or did that change?
-Arne

RIDDICK

i just installed rxtx.x86_64 (for fedora 10 currently: 0:2.1-0.2.7r2.fc10)...
and removed the lib/librxtxSerial.so file in the arduino 0013 directory
and soft-linked /usr/lib64/rxtx/librxtxSerial.so to lib/librxtxSerial.so...

it can compile and upload on amd64 now... natively... :-)

WOOOT!
-Arne

madworm

This works for openSUSE as well :-)

They provide rxtx-java packages on their download site via software search. I updated the installation manuals on the playground for this distribution.
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

mlindeblom

In todays jaunty 9.04 librxtx-java 2.1.7r2-4 failed on X86_64; however:
the version from http://rxtx.qbang.org/pub/rxtx/rxtx-2.2pre2-bins.zip
works fine.

Go Up