Go Down

Topic: Bootloader won't burn on 328p (Read 666 times) previous topic - next topic

Things

Aug 19, 2011, 12:42 pm Last Edit: Aug 19, 2011, 01:10 pm by Things Reason: 1
OK, so I have a blank ATMega328-PU in an Arduino duemilanove board, trying to burn the bootloader is per this config:
http://arduino.cc/en/uploads/Tutorial/arduinoisp.png

I am using arduino 0022, on Windows 7 using both duemilanove boards. I have the board and com ports set correct, all my wiring is right, however I get:

avrdude: stk500_getsync(): not in sync: resp=0x15

I tried adding 3 330 ohm resistors in parralel between the 5V and reset pin on the programmer arduino, and it then gives me this error instead:

avrdude: Expected signature for ATMEGA328P is 1E 95 0F
         Double check chip, or use -F to override this check.

Not really sure where to go from here, though I have 10 ATMega328-PU's I need to burn ASAP, and this isn't helping :(

Is there something different in burning ATMega328-PU's instead of 328p-PU's?

EDIT: Nevermind, I found this thread and it seems to have worked: http://arduino.cc/forum/index.php?topic=58670.0

Thanks

Nadir

I am not sure but please try this,

Change

atmega328.build.mcu=atmega328p

to

atmega328.build.mcu=atmega328

in boards.txt

treebykooba

i'm no expert...but i was having this same problem..switched to the old 018 build...and now it's fine for some reason...

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy