Go Down

Topic: Problemas con Arduino Uno y librerias [solucionado 2/3] (Read 1 time) previous topic - next topic

Lord_Sprit

Aug 19, 2011, 01:20 pm Last Edit: Aug 19, 2011, 02:58 pm by Lord_Sprit Reason: 1
Buenas

Mi problema es que ya van 3 proyectos que se me quedan a medias porque incluyen librerías y no me funcionan cuando cargo el sketch en arduino.
El primer proyecto fue con la librería servo que viene incluida en los sketch de prueba, abrí el sketch Sweep de los ejemplos de servo, lo compilo perfectamente y lo cargo sin problemas pero no funciono.
En cambio hice lo mismo sin librerías de manera directa y conseguí que se moviera el servo.

El siguiente proyecto fue una matriz led de 8x8, con la que me ocurrió lo mismo, conectándola de manera directa a arduino hice un hello world perfectamente pero conectándola a través del IC MAX7219 y siguiendo los pasos del playground con su librería y todo tampoco conseguí que me funcionara pese a compilar y cargar perfectamente.

El tercer proyecto fue hace unos días, me adjudique una pantalla LCD monocroma compatible con Hitachi HD44780 para la cual también hay librerías en el propio ide de arduino(LiquidCrystal/HelloWorld) pero tampoco funcionaron.Tutorial seguido para conectarla.

Dados los 3 casos con las coincidencias de las librerías paso a preguntar si es cosa de que tenga mal configurado el ide (version 0022) o que puede ser.
Ya que los sketches vienen en el ide, cargan y compilan bien. Y creo que se suficiente de electrónica como para conectar un servo.......

ionhs

Que versión del IDE tienes la ultima es la 22. En las versiones antiguas algunas librerías no se han metido. Salu2


ionhs

Yo que tu dejaba de seguir probando proyectos y centrate en uno hasta que te salga. Vete comentando lo que vas haciendo y la gente te irá dando ideas.

Yo he usado el del sero http://arduino.cc/en/Tutorial/Sweep como está sin cambiar nada y funciona, es muy sencillo. Salu2

Lord_Sprit

Probare de nuevo e iré comentando aquí gracias^^

Lord_Sprit

He conseguido 2 de 3, la librería del servo no la cargaba bien pero tras seguir tu enlace lo corregí.

La siguiente no era una librería era un sketch y cuando lo use no lo habían corregido, ahora alguien puso unas cuantas correcciones que la aplicarlas aparentemente funciona. Lo tendré que procesar un pelin mas a fondo para ver si me da otros errores pero en principio va bien.MAX7219

En cuanto al LCD cuando tenga tiempo lo miro y te digo.

Muchísimas gracias, ya pensaba que tenia mal la placa o asín.

P.D: Cambio el titulo del tema

ionhs

Al final no eran las librerías, eran pequeños errores. Yo siempre suele mirar en español (para hacerme una idea) y luego en ingles ya que el segundo suele estar un poco más actualizado. Salu2

Go Up