Go Down

Topic: * MP3 Shield * - Rogue Robotics rMP3 (Read 44 times) previous topic - next topic

jennyc

Just been trying to get it even playing an mp3, and it never compiles. Just gets the same error every time.
Code: [Select]
In file included from sketch_jan17a.cpp:1:
C:\Users\Jennifer\Desktop\arduino-0022\libraries\NewSoftSerial/NewSoftSerial.h:32:24: error: SerialBase.h: No such file or directory
In file included from sketch_jan17a.cpp:1:
C:\Users\Jennifer\Desktop\arduino-0022\libraries\NewSoftSerial/NewSoftSerial.h:45: error: expected class-name before '{' token
sketch_jan17a:4: error: no matching function for call to 'RogueMP3::RogueMP3(NewSoftSerial&)'
C:\Users\Jennifer\Desktop\arduino-0022\libraries\RogueMP3/RogueMP3.h:110: note: candidates are: RogueMP3::RogueMP3(Stream&)
C:\Users\Jennifer\Desktop\arduino-0022\libraries\RogueMP3/RogueMP3.h:103: note:                 RogueMP3::RogueMP3(const RogueMP3&)


And I have no idea why it is not working. I have downloaded, and installed the serials library change, and selected the [stream] uno module.

Any ideas what the issue might be?

bhagman

@jennyc:  The problem is that you need to use a more recent version of NewSoftSerial.  There are two ways to get a newer version:



Try one of those, and see how it goes.

(it looks like you were using the "SerialBase" version of NewSoftSerial - I know it's confusing - It'll be straightened out soon enough).

b

mowcius

With 0022, serial base class is included as standard so you do not need the (stream) versions.

jennyc

I think I was using the NewSoftSerial library. I downloaded it, and pasted it into the /library/ folder at my arduino location. Is that all I had to do?

I have also since tried it without the stream versions, and still the same error.

I have been told that I may have to check the instantiation? I'm not sure what this is, as I only saw it online in relation to the ump3 device.

When attaching my uno to the rmp3, am I correct in just lining up all the pins and attaching? The activity light flashes for a brief moment on the rmp3, then just goes off, and Windows makes the "hardware plugged in" sound, then the removed sound, while the uno is just loop playing the blink programme that I loaded onto it.

bhagman

#164
Jan 19, 2011, 12:06 am Last Edit: Jan 19, 2011, 12:08 am by bhagman Reason: 1
@jennyc:  Make sure you delete any other versions of NewSoftSerial from your /libraries/ folder (I assume that is what you meant - if not, you need to use that folder instead).  Then use this version of NewSoftSerial:

http://code.google.com/p/rogue-code/downloads/detail?name=NewSoftSerial10c-withMegaAndStream.zip


The start-up sounds right.  Activity LED should flash briefly, then turn off.  Just make sure that the controller board (Uno) is not connected to the computer when you attach the rMP3.  After attaching, plug the rig into your computer.

b

Go Up