Go Down

Topic: Kit robotic Arduino 2WD fonctionnement des moteurs? (Read 1 time) previous topic - next topic

31mc

Bonjour, tout d'abord je tiens a dire que je suis nouveau dans la communauté arduino, et que c'est mon premier montage arduino, je suis donc un débutant qui galère (pour l'instant), et j'espère que vous saurez m'aider.
Voila mon problème:
J'ai acheté un kit robotic 2 roues a monter celui-ci :http://www.bizoner.com/arduino-2wd-aluminum-alloy-2-wheel-drive-mobile-robot-chassis-p-213.html.
J'ai aussi une carte arduino duemilanove ainsi que shield IO Expansion board celui-ci : http://www.bizoner.com/arduino-duemilanove-io-expansion-shield-xbee-bluetooth-sd-card-p-208.html
J'ai monté les moteurs avec les roues puis lorsque je connecte les moteurs au rs485 du shield avec une alimentation, un des moteurs fonctionne a fond sans s'arrêter, je ne comprend pas pourquoi?
sur l'arduino le code est le "Blink" de base.
J'aimerais que l'on m'explique pourquoi un des moteurs tourne sans cesse (pas le second ) et que dois-je faire? qu'est ce que je fais de mal ou que je ne fais pas?
Je le répete je suis novice XD.
Merci pour vos réponse.

chicotore

C'est le code dans ton arduino qui doit être mauvais  ;)

Tu n'a pas de "moteur shield" ? tu aurait un schémas de ton montage actuel ?
Mon Blog sur l'environnement Arduino ... Tutos fait par un débutant pour les débutants ^^

http://chicowebsite.free.fr/

fdufnews

Quote
J'aimerais que l'on m'explique pourquoi un des moteurs tourne sans cesse (pas le second ) et que dois-je faire? qu'est ce que je fais de mal ou que je ne fais pas?

Dans la description de ton montage on ne voit aucune carte ou circuit pour piloter les moteurs. Je ne suis pas loin de penser que tu alimentes des moteurs n'importe comment. Prions pour que ta carte arduino et/ou ton shield ne soit pas bousillé.

31mc

Mon montage est le suivant carte arduino duemilanove avec carte IO shield (ou moteur shield???)
Quote
shield IO Expansion board celui-ci : http://www.bizoner.com/arduino-duemilanove-io-expansion-shield-xbee-bluetooth-sd-card-p-208.html

qui est monté dessus. Je connecte alors les moteurs sur cette carte.
Avec une alimentation 6 piles aa sur le jack de connection alim.
Pour résumer : Alim 6x pile aa->Duemilanove->IO Shield->moteurs

fdufnews

Quote
Mon montage est le suivant carte arduino duemilanove avec carte IO shield (ou moteur shield???)

La carte IO shield, pour ce que j'en ai vu, n'a aucune ressource pour piloter un moteur.

31mc

Ha :smiley-roll-sweat:, je croyais que cette carte pouvait contrôler des moteurs.
Je ferais mieux de vite changer de montage, est-ce qu'une carte ROMEO irez bien?

Teiva

Bonjour,
En effet le shield que tu as pris ne permet pas de piloter des moteurs, La Romeo convient très bien et est vraiment pratique pour ce genre de robot, sinon si tu as déjà une carte arduino tu peux rajouter un shield contrôleur de moteur à base de L298, il existe aussi des modules indépendant à base de L298.
Il y a aussi un shield à base de L293 mais il est juste suffisant pour ce robot.

A+ Teiva


www.Zartronic.fr : Arduino & Robotique

31mc


Go Up