Go Down

Topic: Two arduino IDE in the same computer? (Read 747 times) previous topic - next topic

madepablo

Hi,

I was working with Arduino Duemilanove and Arduino 017 for two years. Now i have an arduino mega 2560, so i want to install the last Arduino IDE (22).

The problem is that with the new arduino will not work the previous working sketches that i have for duemilanove and IDE 17.

So i would like to know if i could have two IDE installed at the same windows xp computer in order to run version 17 when i will work with arduino duemilanove without to modify my working codes, and to run version 22 when i will work with mega 2560...

Thanks!

Noorman

You can simply install the new version in a folder called eg arduino22.
The old verion in a folder called arduino17.
Create shortcuts in the place you want to start them from.
This should work.

There is one uncertainty and that is the dll files for the (usb) communication, that might not work.

2B || !2B

... bonding electrons and bits!

robtillaart

There are some interfaces changed during the evolution of the Arduino "language", e.g. The ethernet lib is now SPI based -> add  #include <SPI.h>

If you want help to fix (version 17) code please post it allong with its error messages

Rob
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

madepablo

Thanks to both!

So, for the reply from Noorman, i understand that i could have multiple ide installed on the same computer, and from robtillaart, that (at least for the moment), including this simple command, i could use my old codes with the new version.

Thanks to both. I will start installing the new version and see if i could solve the problems. If not, i will report the error message. Thanks to all!

pluggy

http://pluggy.is-a-geek.com/index.html

Noorman

2B || !2B

... bonding electrons and bits!

robtillaart

Now who is the first with a screenshot of all 22 versions ;)
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

sciguy

#7
Aug 27, 2011, 03:41 pm Last Edit: Aug 27, 2011, 04:09 pm by sciguy Reason: 1
FAAAKE!!

I can tell it's photoshopped because of the pixels and I have seen a lot of photoshop things.



Kidding, but I agree the all 22 versions idea would be awesome.



=(
I downloaded every version, but nothing 16 and before will run correctly.  Upon opening, it gives me java errors.
Oh well.
Soundcloud page: http://soundcloud.com/beefinator-2
Youtube channel: http://www.youtube.com/user/beefinator14
Old soundcloud page (ran out o

pluggy

Mine were what were already installed.  0020 had a very short life and I moved directly from 0019 to 0021.  0022 has had a very long life, longer than all the other versions I've used (0014 onwards but not on this computer). 
http://pluggy.is-a-geek.com/index.html

Go Up