Go Down

Topic: Il mio intervaluino non va (Read 2450 times) previous topic - next topic

lollotek

hai provato a caricarci altri sketch?
hai altri arduino per fare altre prove?
hai provato a programmare da un'altro pc?
hai provato a cambiare la porta usb?

quando le cose non vanno bisogna sempre andare un po' a tentativi ...

bibopm

Non ho altre schede da provare ma ho cambiato le porte e lo sketch. Inivia a caricare, la spia rx fa tre lampeggi e poi niente

lollotek

bho, onestamente a me pare che quando fa così è perché c'è il tipo di board errato...

bibopm

E' sempre stato un 2009 con atmega 328

leo72

Se hai Windows, prova a reinstallare i driver. Poi prova anche a rimettere l'IDE.

Prova anche a staccare tutto il circuito ed a programmare l'Arduino senza niente collegato.

lollotek

c'è qualche problema di comunicazione, non c'è una soluzione universale.
fai come consiglia leo72, poi guarda anche qui e qui.
Hai anche detto che hai cambiato l'atmega, ma ha il bootloader?

leo72


Hai anche detto che hai cambiato l'atmega, ma ha il bootloader?


Mi era sfuggita, 'sta cosa... bella domanda. Se l'Atmega non ha il bootloader, non lo programmi di certo (con l'Arduino).

bibopm

Sto scaricando il software per installarlo nuovamente, appena ho notizie vi aggiorno. Il micro l'ho comprato gia con il boot installato per non aver problemi

ratto93

Dimenticate una cosa.....
lo sketck era per un tiny 85 però è stato messo in un ATmega... in corrispondenza dei pin usati dalle funzioni dell'intervallometro stesso ci sono i pi della seriale quindi forse vanno in conflitto....
prova a schiaccire il bottone di reset un attimo prima di premere l'upload....
Se corri veloce come un fulmine, ti schianterai come un tuono.

bibopm

Aggiornato il programma e adesso ha caricato...finalmente va. Ora devo far funzionare la parte hardware. Credo che sui fotoaccoppiatori ho messo i cavi sbagliati

bibopm

Se schiaccio il tasto sulla bread non va il circuito...è una tragedia

bibopm

Posto lo schema del mio progetto. Spero che qualcuno capisca  :smiley-sleep:

leo72

Non potresti allegare anche un'immagine JPEG?

Testato

#28
Sep 01, 2011, 12:20 am Last Edit: Sep 01, 2011, 12:36 am by Testato Reason: 1
.
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

Testato

#29
Sep 01, 2011, 12:39 am Last Edit: Sep 01, 2011, 12:43 am by Testato Reason: 1
Il primo errore che vedo e' che hai messo una pull-up di soli 220 ohm sul pulsante, questo non va bene
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

Go Up