Go Down

Topic: Wave shield: problema di saldatura? (Read 1 time) previous topic - next topic

arduaudio

Ciao a tutti,
ho provato ad assemblare il wave shield (è la prima volta che uso il saldatore in vita mia :D è venuto uno schifo, lo so  ]:D), il problema è che non inizializza la SD. Ho provato anche con altre lib per SD, ma falliscono tutte all'inizializzazione. Evidentemente il problema sta nella saldatura, ma non riesco proprio a capire dove. Potreste dargli un'occhiata? http://imageshack.us/g/710/20110831103838.jpg/
Grazie infinite
P.S.= le foto non sono venute un granchè, servono di migliori qualità?  :)

KrashNet


Ciao a tutti,
ho provato ad assemblare il wave shield (è la prima volta che uso il saldatore in vita mia :D è venuto uno schifo, lo so  ]:D), il problema è che non inizializza la SD. Ho provato anche con altre lib per SD, ma falliscono tutte all'inizializzazione. Evidentemente il problema sta nella saldatura, ma non riesco proprio a capire dove. Potreste dargli un'occhiata? http://imageshack.us/g/710/20110831103838.jpg/
Grazie infinite
P.S.= le foto non sono venute un granchè, servono di migliori qualità?  :)



Per le foto, dovresti staccare lo shield e farci vedere la parte superiore e inferiore, poi dovresti usare se c'è, la modalità macro... e magari incrementare un po la luce e cercare di non farle mosse!  :smiley-mr-green:
.

arduaudio

Ok, cerco di fare le foto con la Nikon, invece che con l'android. Quanto allo staccare lo shield non credo proprio sia possibile: i pin sono saldati. C'era scritto di fare così sul tutorial ladyada (http://www.ladyada.net/images/wavshield/v11/headersolder.jpg) e io l'ho fatto  :smiley-mr-green:

ratto93

Senza il lato saldature non possiamo dirti nulla :)
Se corri veloce come un fulmine, ti schianterai come un tuono.

arduaudio

Che intedete per lato saldature? Mica posso staccarla ora!
Ecco delle foto migliori http://web01.altervista.org/waveshield/index.php

ratto93

D'OH....
sono a definizione alta mi ci vorrà una vita ad aprirle =(
Se corri veloce come un fulmine, ti schianterai come un tuono.

arduaudio

se vuoi le ridimensiono... anche io per caricarle c'ho messo un sacco di tempo, ma non avevo il tempo di fare in altro modo.

Guglio

Bastano due foto dall' alto, mettendo a fuoco i collegamenti.
E due del "sotto" la scheda!
ArduMAP: Mappa degli utenti che utilizzano Arduino.
http://www.guglio.net/ArduMAP

KrashNet

Secondo me devi controllare bene le saldature... perchè come vedi nell'immagine allegata... può essere che nel lato sotto li hai saldati bene ma sopra no quindi c'è qualche contatto che non contatta!
Non so se mi sono capito  :D


Cmq io intendevo.... staccala dall'arduino (tanto è infilata apressione) e fai 1 bella foto non mossa della parte sotto
e 1 bella foto non mossa della parte sopra!
.

Federico

Certo che come fotografo non sei il massimo :-)
E mi sa neanche come saldatore!
Hai preso un bal progetto difficile per essere la prima volta...

Cosi, a occhio e croce, mi pare che molte saldature siano imperfette, ma dovresti controllare col tester. Lo possiedi?

Fede
Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

arduaudio


Certo che come fotografo non sei il massimo :-)
E mi sa neanche come saldatore!
Hai preso un bal progetto difficile per essere la prima volta...

Cosi, a occhio e croce, mi pare che molte saldature siano imperfette, ma dovresti controllare col tester. Lo possiedi?

Fede

Eh, simpaticone, luce scarsa, fotocamera indecente, batterie scariche (niente flash) e prova un po' tu :D
Ho letto troppo velocemente la descrizione di adafruit e non ho realizzato che era da saldare. Pensa la sorpresa quando ho aperto il pacco! Non ho nessun tester e preferirei non comprarlo, visto che finora ho speso, tra spedizione USA, sensori, saldatore e cose del genere, più o meno cinque volte quanto avevo previsto  ]:D. Proverò a controllare la saldature una ad una.

arduaudio


Secondo me devi controllare bene le saldature... perchè come vedi nell'immagine allegata... può essere che nel lato sotto li hai saldati bene ma sopra no quindi c'è qualche contatto che non contatta!
Non so se mi sono capito  :D


Cmq io intendevo.... staccala dall'arduino (tanto è infilata apressione) e fai 1 bella foto non mossa della parte sotto
e 1 bella foto non mossa della parte sopra!

capito, appena posso lo faccio!

Michele Menniti

Beh, le foto mosse non dipendono da nessuno dei fattori che hai indicato, forse da un cicchetto di vino in più  :smiley-yell:
Ma hai saldato gli integrati direttamente sulla scheda senza usare zoccoli? Considerando che non hai molta esperienza non è impossibile che tu ne abbia danneggiato qualcuno, non è stata una bella mossa quella :smiley-eek-blue:
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

arduaudio

Beh sarà stato il fatto che avevo appena finito di saldare una 50ina di pin e avevo gli occhi praticamente sciolti  :smiley-eek-blue: :smiley-eek-blue:...P.S.= bevo vino e alcolici cinque volte all'anno, forse, d'accordo che l'ultima volta l'ho fatto tre giorni fa, ma non credo sia quello :D :D Gli zoccoli non li ho usati perchè non c'erano nel tutorial ladyada ed è il primo circuito che assemblo!

Federico

Cavolo dovevi usare gli zoccoli, se non c'erano era meglio procurarseli. Essendo proprio il primo circuito che assembli, e forse non ci hai messo 2-3 sec max a punto, potresti anche aver bruciato l'integrato...
Il tester invece e' un investimento che devi fare, non puoi controllare le saldature senza. Anche se ad occhio sembrano ok, magari non lo sono elettricamente. Investi 'sti 10euro per il tester piu' sgrauso che trovi!
Prendila sul ridere ma ti occorrono gli strumenti giusti per fare un lavoro funzionante!
Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview