Pages: [1]   Go Down
Author Topic: Stepper motor wiggles... doesn't turn...  (Read 1340 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi there

I try to run some stepper motors with my arduino, but have some problems.

I have the following setup:

Arduino Mega
Stepper Driver: Pololu A4988: http://www.pololu.com/catalog/product/1183
Stepper Motor: Nanotec ST2818L1006-A http://de.nanotec.com/downloads/pdf/1199/ST2818L1006.pdf
Power Supply: sunpower S-100F-24 http://www.sunpower-uk.com/product/S-100F-24/S-100F-24/default.htm

First i tried to run another motor for testing, and this did work quite fine. (It was a mercury  motor SM-42BYG011-25)
I could do with it all i wanted with the AccelStepper Library.

But then, when I tried to run the same script with the Nanotec motor, nothing happend but an unconstantly wiggling...
What could be the problem?

I'm not 100% shure if I connected it right. As you can see in the datasheet, I tried the Bipolar serial connection.
Therefore i only connected the black&green and the blue&red cables to my motordriver.

Another question is the current limiting. Do I have to limit it to 0.69A (because the motor has a max. of 0.69A/Phase) or
do I have to limit it to 2x0.69A = 1.34A, because it has two phases? What is the easiest way to measure this limited current?

I would really happy if someone could help me with that.

Thanks and regards
T
Logged

0
Offline Offline
Shannon Member
****
Karma: 200
Posts: 11694
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Double-check the wiring (with multimeter).  Small amplitude wiggling suggests only one winding is being energized.

And yes you must limit the current - some older motors are permanently remagnetised if over-driven and if you saturate the magnetic circuit you waste lots of power.  Also the motor will overheat.

Have you first tried with a lower voltage supply to the Pololu controller and with slow (micro) stepping?
Logged

[ I won't respond to messages, use the forum please ]

Pages: [1]   Go Up
Jump to: