Go Down

Topic: Programmer not responding (Read 910 times) previous topic - next topic


Hi.. I'm quite new to Arduino (2 days working with it) but very experienced in electronics and microcontrollers.

I have a Uno board connected to an iMac via USB and all was working well (have been developing my code for a couple of days now and have programmed the board and moved it to the target environmnenrt maybe 50 times. Was very happy with the hardware and software.

Until a few minutes ago when I started to get the message .. avrdude: stk500_recv(): programmer is not responding .. when trying to load the board. And now nothing I do seems to be able to get it working again (I've gone back to the 'blink' example to see if I can get that going again but so far, no success).

When I press reset, the LED blink 3 times very quickly (same when I first plug in the USB).
When I try to upload the board, there is no obvious LED activity.

I've tried hitting reset while attempting to upload but to no avail.
I've also tried a different USB port on the Mac.

Problem seem to start when I forgot to plug in the USB to the Uno when doing an upload and maybe connected it partway through an upload.

I've tried powering the Mac on and off but no change. Have checked the Mac USB ports with an iPhone and they are fine.

Any suggestions please ? My project was going so well and I was singing praises of Arduino to all my friends and then this happened !



Apologies ... problem fixed ... needed to reselect the serial port from tools->serial port menu. Seems that the driver drops off the board if it finds that it is isn't there at any time it tries to communicated with it.

Panic over .. back to having fun.


Good news: Thanks for saving me the trouble of writing pretty much the exactly same email.
Bad news: I haven't got a solution for you - yet at least :(

I've played with Arduino Uno so far without any problems and received my Arduino Nano from Dealextreme today. Did a couple of tests with it, everything seemed to work fine, but after a while I managed to get it into exactly the same state you described, apart from the fact that the RX led seems to lit a bit when doing the upload, but it fails the same way nevertheless.

The program I wrote before and uploaded still works, but I can't seem to get anything uploaded there anymore. I've tried pressing the reset button on all the possible combinations before and after pressing the upload command from the IDE, but always with same results.

Is the nano a goner or is there any way of reprogramming it? I know ISP might be a solution, but since I don't know how exactly those work with Nano, would it mean I had to solder out the chip for that or what?

Likewise working with Mac and latest OSX Lion. No luck with two separate laptops. The uno still works nicely though, so probably my usb/serial is still okay.

But halp   :smiley-eek:

Go Up