Go Down

Topic: Hope this is the right forum (Read 2380 times) previous topic - next topic


Hi , I hope am posting in the right section of the forum .

I have 2 questions that are probably simple but I just dont know the answer and
they are driving me nuts

    When I run a the serial monitor on the IDE it defaults I think to 9600 baud. If my sketch requires
it to run at lets say 38400 then I am stuck. The only way I found to get around it was to run an external terminal prog
such as Brays or putty that lets me choose the baud rate.  Is it possible to alter the baud rate on the IDE's serial monitor ?

   I put my Arduino files on my "D" drive rather than the normal "C" drive .
I would like to be able to click on a file with extention pde and have it start up the IDE to view it
but for some reason my pde files all have an adobe acrobat icon and try to open adobe reader.
I tried clicking on the file and changing " opens with"  but it only allows me to select a program that was
installed by windows , and of course my Arduino IDE was not installed by windows it was just a directory
of files put onto my "D" drive .
How can I get it to accept that the Aduino IDE is the program that should open all pde files 



I can answer #1. Open the IDE serial window. Look in the lower right corner.


Hi Surfer Tim

Now I do feel silly ,  of all the times I opened the serial monitor I always looked across the top
for a place to make setting changes , I never once looked at the bottom . Its a bit obvious once you know  :smiley-red:

Does anyone know the answer to the second question ?



Sep 09, 2011, 02:02 pm Last Edit: Sep 09, 2011, 02:04 pm by SurferTim Reason: 1
Guess this is me again. I do know how to use Windoze also.  ;)

1) open Windows Explorer
2) select tools - folder options on the menu
3) select "file types" tab.
4) find and highlight PDE
5) select "change"
6) select the browse button (tricked you again! Bottom!)


Hello Don.

To the second one, you can choose the program that you want to use doing:
-push CAPS (the left one) and click with the ritght mouse button .
-Choose    open with
- Choose the program looking for it with the examine option (en español es la opción de examinar).
- Mark the option to do this allways.
- And ACEPT,   thats all.

Sorry for my English


Hi Surfer Tim
                    Your tricking me this time.

You wrote....

1) open Windows Explorer          I did that
2) select tools - folder options on the menu  I did that
3) select "file types" tab.    I havent got a files type tab , I have General, View, Search

I am using Vista , does that make a difference?



My bad! I am using Windows XP. I will guess that makes a difference. Did you try the other solution offered?


         that's what I had tried before ,

it only lets you chose a program that was installed by windows ( and I guess it has to have entries in the registry)

Because my Arduino files are just in a directory dumped on my 2nd HDD it wont let me chose it,
well actually I can choose it but then it ignores it.



Hi Tim
          I just put on my laptop ( running XP)

I right clicked on a pde file and it let me browse to my
Arduino folder and choose the IDE .
Now when I double click on any pde it opens in the IDE as we wanted

For reasons I dont understand I cant seem to do that in Vista .
when I browse to the Arduino folder and click on the IDE app it
doesnt then appear in the list of progs I can choose to always open
the pde file. Its as if you can only choose progs that were INSTALLED by windows

Hopefully someone else is running Vista and will know the answer


Coding Badly

• Using Explorer, navigate to a PDE file

• Right-click on the PDE file to display the Context Menu

• Click Open With then click Choose Default Program

• If Arduino is in the list, ensure it is selected.  If not, check under Other Programs.  If not there either, use the Browse button to select Arduino.

• Ensure Always use the selected program to open this kind of file is selected

• Click OK


When I used to work with XP and wanted to change the default application for some file what I did was:

1. Press SHIFT and right click on any file  with the required extension
2. Click on "open with"
3. Choose the program in the list if its there, otherwise click on other files(something like that). Select the application
4. Click on the check box that says something like " Always use this program to open files of this kind"
5.Click ok

Hope it works on other windows as well


Thanks for the reply but thats what I have been trying all day

On my windows XP machine that works fine , but on my Vista machines it wont have it

The arduino is not in the list of programs you can select from to open the file so as you said
we browse to it . click on the arduino IDE app and do ok but although we click on it , when it
returns to the list of progs we can choose from the list still does not contain it .

I have tried this on 3 different machines that all have Vista OS and it fails on all 3 for me .
Normally a prog comes with a windows installer but arduino is just a case of download , unzip and place the folder
in a place of your choosing .
On one machine I put the arduino folder in C drive , in another PC its in D drive , and in the 3rd its on the desktop .

I believe that unless a program is installed by windows ( so it makes a Reg entry) it will not let you select it as the program
to run your file extention. At least that is what seems to be happening.
On the XP machine it works fine , its only the vista machines that fail.



Just to add a bit more

I just d/l arduino software onto a machine with Win7

I unzipped it and dumped it on the desktop.

I right clicked a sketch and said open, It asked what prog to use,
as Arduino is not in the list I did browse and went to the arduino folder
and selected the IDE app and ok'd it. It imediately appeared in the list of progs
I can choose to open .pde extentions. I select use allways , and it works fine

So to clarify I did the same thing on XP, Vista aand win 7 machines,
On win 7 and XP it works fine , but on 3 vista machines  ... nothing



I'm running vista on my laptop. When I right click on a pde file and select Open With... it has arduino at the top of Recommended Programs. I'm not sure why it's not working for you.


Hi Texy
           thats really strange  how it works on your laptop and not on any of mine .

What I dont understand is how windows knows that the arduino program actually exists
on your pc to make it available as a suitable program to open pde files ,because it doesnt get installed ,
its just a folder full of files dumped onto your hard drive

If we actually installed the IDE software then fair enough,  windows knows the IDE exists and
cold recommend its use for pde files  , but we dont install it , we just extract the folder from
the zip onto the HDD

I cant work that out


Go Up