Go Down

Topic: Compile Speed - testing & feedback needed! (Read 9 times) previous topic - next topic

WizenedEE

I have the git version of arduino, and the feature has worked properly for me for quite some time (months). Here's wiring.c.d after hitting verify twice

MGeo

#36
Jun 17, 2012, 01:05 pm Last Edit: Jun 17, 2012, 01:18 pm by MGeo Reason: 1
Thanks for posting.  Dependencies look similar to mine.  Looks like they are not supposed to change 1st run to subsequent runs.  Guess that makes sense.  The messed up path showns in the .d files on my Win 7 machine looks like a clue.  Hmmm...

Code: [Select]
\
C:\DOCUME~1\gsmall\LOCALS~1\Temp\build3787739127124592615.tmp\wiring_digital.c.o:  \
C:\Program\ Files\arduino-1.0.1\hardware\arduino\cores\arduino\wiring_digital.c \
  C:\Program\ Files\arduino-1.0.1\hardware\arduino\cores\arduino\/wiring_private.h \
  C:\Program\ Files\arduino-1.0.1\hardware\arduino\cores\arduino\/Arduino.h \
  C:\Program\ Files\arduino-1.0.1\hardware\arduino\cores\arduino\/binary.h \
  C:\Program\ Files\arduino-1.0.1\hardware\arduino\variants\standard/pins_arduino.h

Paul Stoffregen

If you move your arduino-1.0.1 from C:\Program Files to just C:\ (at least temporarily for the sake of testing), does that make this magically start working?

FYI: lately I haven't had any time for Arduino hacking... 2 huge project deadlines, one recently passed, the other is a huge interactive fire art installation that shows next weekend.  I plan to look into this issue in early July.  If you could confirm (or refute) that moving the just C:\ fixes the problem before then, please do.

timkay

It's been 2 years since this issue was discussed but never resolved.

I am confirming that, YES, moving the Arduino folder from C:\Program Files to just C:\ resolves this issue. I see a speed up of at least 8X using 1.05-r2.

Paul Stoffregen

Oh, yeah, I fixed this a very long time ago.  But the fix has never worked its way back into the official Arduino sources.

Here's the code with the fix, if anyone's interested.

Go Up