Go Down

Topic: "not in sync" after successfully burning UNO bootloader to a duemilanove (Read 2101 times) previous topic - next topic

liudr

I burned UNO bootloader with an UNO to a Duemilanove successfully. No error message. Now I wanted to load sketch to this duemilanove, choosing UNO as the board and I got this:

avrdude: stk500_getsync(): not in sync: resp=0x00

The L has 3 rapid flashes, and then repeat these flashes.

I've done this with an older duemilanove with a zif on it to bootload a whole bunch chips. This non-working re-bootloaded duemilanove is a newer one I got after UNO was already released. No idea why thou? Any help is appreciated!

liudr

Now I re-bootloaded the duemilanove and was able to load blink without delay. Now it's stuck with this sketch and won't load other code:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

:((

Coding Badly


Are you installing the bootloader using the IDE?  Or using AVRDUDE from the command-line?

liudr



Are you installing the bootloader using the IDE?  Or using AVRDUDE from the command-line?



Using arduino IDE 0022. Any reliability issue with bootloading via the IDE?

Coding Badly


I have not read of any.  The IDE seems to be very reliable at installing a bootloader.

Coding Badly


Just to make certain I understand: The goal is to get the Uno bootloader installed on a 328 processor using an Uno as a programmer.  Correct?

liudr

Yes. I have done this at least 10 times, either wiring up the uno to an atmega328P on a breadboard or dropping an atmega328P on an older duemilanove with a zif.

Coding Badly


Did you use the latest bootloader?  The one published here...
http://arduino.cc/forum/index.php/topic,64105.0.html

liudr



Did you use the latest bootloader?  The one published here...
http://arduino.cc/forum/index.php/topic,64105.0.html


Not yet. What I did was downloading arduino 0022 and used a newly bought uno to do bootload with arduino as isp. I will read through that thread and see if I should be doing something differently. I suppose all that matters is the arduino IDE version, which has the compiled bootloaders, right? (maybe wrong :()

Coding Badly

Quote
I suppose all that matters is the arduino IDE version, which has the compiled bootloaders, right?


I believe the Uno bootloader included with Arduino IDE 0022 is buggy.  I think that explains the symptoms you are seeing.  I suggest replacing the Uno bootloader hex file on your computer with the one in that topic.

What happens with you try again to burn a bootloader to the Duemilanove?

liudr

Thanks Coding Badly.

That discussion was very long. I will need to find time to read through it with tea. For now I just tried again with original optiboot with arduinoISP to confirm that bootloading the chip in question will not solve the problem. The newly bootloaded chip fails to accept any sketch. Then I downloaded westfw's new bootloader hex file, used ArduinoISP again and I was able to load two sketches so far with no problem!

Hail to westfw!

I will try the optiloader as well. I'll be ordering a bunch of atmega328P and was dreading on the bootloading process but this sketch will help a lot. Seems you just need to bootload, hit reset and do it again on the next chip.

Go Up