Using Arduino > Microcontrollers

Attiny85 and Pololu USB programmer (solved)

(1/2) > >>

Erni:
Hi,

I have had a good time experimenting with the Attiny 85, using Arduino as ISP. I'am impressed what you an do with such a small device.

Now I would like to use a programmer, so I bought a pololu USB AVR Programmer, and then my trouble began.

Im using Coing Badly's core:

I ammended this to programmers.txt :

pololu.name=pololu USB AVR Programmer
pololu.communication=serial
Pololu.protocol=avrispv2
#arduinoisp.speed=19200

and the bords.txt:

# The following DO work (pick one)...
# attiny85at8.upload.protocol=avrispv2
# attiny85at8.upload.using=arduino:arduinoisp
attiny85at8.upload.using=arduino:pololu


And then what I think is the prolem, in avrdude.conf I made this entry:

programmer
 id    = "Pololu";
 desc  = "pololu USB AVR Programmer";
 type  = avrispv2;


When uploading the blink sketch I get this message from the Arduiono IDE

Binary sketch size: 748 bytes (of a 8192 byte maximum)
error at D:\Ernst\arduino\arduino-0021\hardware/tools/avr/etc/avrdude.conf:387 unrecognized character: "a"

line 387 is:  type  = avrispv2;

I have tried other names f.:ex: Pololu but no luck
So obviosly I can't just make a new type, so what to do


Any Ideas??

putyn:
i think you should  respect lowercase/uppercase i see on the first 2 lines pololu written with lowercase p , but the last line is written with uppercase p not sure if will work but you can try :D

Erni:


Thakyou for your answer putyn, I have tried making all pololu names lower case, but no luck

Coding Badly:

--- Quote ---I ammended this to programmers.txt :
--- End quote ---


Which one?  The one in the Arduino directory or the one in the Tiny Core directory?

Erni:

I apreciate your help

I only have programmers.txt in the Arduino directory.

I have a boards.txt in both Arduino and Tiny directory

Now I have tried to copy the programmers.txt to the Tiny directory, but it dos not make any difference.

What makes me suspicious about the avrdude.conf is that if I change the type to one of the predetermined type (by this i mean one of the types mentioned in the top of avrdude.conf ) fex. stk500v2  then i get another message

avrdude: stk500v2_command(): command failed
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

Navigation

[0] Message Index

[#] Next page

Go to full version