Go Down

Topic: [SOLVED] YACU : yet another can't upload (UNO R2) (Read 1 time) previous topic - next topic

elpaso

Sep 27, 2011, 09:45 am Last Edit: Sep 27, 2011, 10:09 pm by elpaso Reason: 1
Hi,

I'm sorry that my first post here sounds so bad, but either I'm doing something really silly or we've got a serious bug.

HW:
* brand new UNO

SW:
* Ubuntu Linux (tested several versions and arch 32, 64 & armel)
* Windows 7

SYMPTHOM:
* avrdude: stk500_recv(): programmer is not responding
* no way to upload anything from the IDE (nor from command line)

SOLUTION (temporary):
* you need black magic timing capabilities to press reset button on the board while starting upload command

QUESTION:
* is it really this the way it works ? (I mean you need to press the HW reset button while starting upload)
* is my board broken ?


I've spent half a day before I could upload the first sketch (now I have 80% success, pressing "reset" and "enter" simultaneously with avrdude from the cmdline).
I think I tried every possible combination of hw/sw versions, my conclusion (still in doubt) is that this seems a bootloader problem, the time it accepts the upload is too short: less than one second.

Any known solution to this issue ? It seems I'm not alone, googling for this problem yields hundreds of (unhappy) pages.

I thought I just could press a button from the IDE to upload a sketch, but this was not the case :(


--- Resolved adding a diode as suggested in http://arduino.cc/forum/index.php/topic,73059.0.html



#1
Sep 27, 2011, 06:57 pm Last Edit: Sep 27, 2011, 07:00 pm by legwinskij Reason: 1
Well using manual Reset with Arduino IDE is easy at least for me. Just press the reset button and while holding it press upload. Wait until the message about compiling shows up and then release the reset button.

draythomp

legwinskij, elpaso, the method of holding the reset switch down until the compile finishes is the exact method I use to recover from a watchdog timer mistake.  Just keep it down until the compile message comes up and let go.

Works every time I do it.
Trying to keep my house under control http://www.desert-home.com/

elpaso

#3
Sep 28, 2011, 09:23 am Last Edit: Sep 28, 2011, 09:42 am by elpaso Reason: 1
Thanks to all posters,

I'll try to summarize: in almost all how-to, primers, tutorials etc. the user is instructed to connect the board, start arduino IDE, choose board type an port, open a sketch (blink) an press the upload button.

That's all: no need to press any reset button on Arduino UNO boards.

In my case (and hundreds of similar cases you can find on Google), there is only a limited amount of time (~1-2/10 seconds) to press reset after/before starting upload in order to make the board reset and accept the upload. No way to upload in other manners (holding reset for various amounts of time didn't help, believe me, it took hours of frustrations before I found the unique way to upload my first sketch).

After reading this thread:

http://arduino.cc/forum/index.php?topic=64256.60
and
http://arduino.cc/forum/index.php/topic,73059.0.html

the conclusion is: all the Arduino UNO R2 boards (others as well, maybe) are affected by a serious hardware design bug that prevent them to work as advertised

This bug can be corrected by adding a  diode from RESET pin to 5V pin, I assume this shoud be done with some soldering if you want to maintain the 2 pins free.

Here there is a photo of the soldering fix:
http://arduino.cc/forum/index.php/topic,68936.msg511038.html#msg511038

So, why don't write this in very big uppercase red letters at the top of the troubleshooting section(s) ? It would save a lot of headaches to a lot of people.

Maybe the problem is that some hundred of thousand people would think that the time has come to ask for a board replacement ?






Go Up