Pages: [1]   Go Down
Author Topic: MLX90614 Infrared Thermometer Module No Signal  (Read 1039 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm attempting to hook up the MLX90614 Infrared Thermometer Module sold by parallax to the Arduino Uno but the sensor's serial pin is outputting no data eg. -1 when casted as a int.
I've attempted to follow the instructions from: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1241012329 with absolutely no success.  I copy and paste the raw code changing absolutely nothing and have triple checked my wiring to the sensor and everything matches up with what the data sheet says but still no output.  I think my sensor is failing the PEC test but as far as i can tell their is no way to test this theory.  Also i've tried using multiple digital pins on my Arduino so im 99.99% sure that the problem is not the digital pins on my Arduino.  Lastly i checked the sensors analog I2C signal pin connected to the PIC chip on the module and found a signal at a very fast baud rate followed shortly after by the serial pin signal coming from the module.
Logged

Brunsbüttel, SH, F.Rep.GERM
Offline Offline
God Member
*****
Karma: 4
Posts: 596
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

have u seen this datasheet?
http://www.sparkfun.com/datasheets/Sensors/Temperature/MLX90614_rev001.pdf

do u have pullup resistors on ur SCL/SDA lines?

did u try to use it in PWM mode?
« Last Edit: October 03, 2011, 04:27:32 am by RIDDICK » Logged

-Arne

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello
I use MLX90614 and I can read the temperature from adress 0x07. Now I want to change the emissivity in 0x04 of EEPROM.I tried to change it but I think my sensor now does not work properly.please help me in this case
thanks
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No I have the module version from parallax.  http://www.parallax.com/StoreSearchResults/tabid/768/txtSearch/infrared/List/0/SortField/4/ProductID/539/Default.aspx

The signal is converted from a I2C to a Serial TTL on the module using a pic chip and some other components.  Looking at the module data sheet they put pull up resistors on the circuit the signal is just not being properly sent back to my Arduino.  I'm not sure if the address are responding to my command prompts.
Logged

Pages: [1]   Go Up
Jump to: