Go Down

Topic: 5v project not working on 3.3v (Read 1 time) previous topic - next topic


I don't think so, because it is one of the chips being delivered together with the arduino board, factory settings should work, or not?
But thanks for the advice, I learned something again :D
Anyway, I'll test that when I have time, meanwhile I use a step-up booster for the mcu circuit and the 3.3v to power the motor.


I don't think so, because it is one of the chips being delivered together with the arduino board, factory settings should work, or not?

The standard extended fuse byte in the boards.txt file (used when you use the IDE to burn a bootloader into an atmega328p) is 0x05, which sets the brown-out level to 2.7v typical, 2.9v maximum. That should be OK on 3.3v. However, if your chip has the fuse programmed as 0x04, the brownout level would be 4.3v typical, 4.5v maximum.
Formal verification of safety-critical software, software development, and electronic design and prototyping. See http://www.eschertech.com. Please do not ask for unpaid help via PM, use the forum.


Sorry if that wasn't clear enough.
Its not a source problem for sure. The current draw of the test installation is below the rated 50mA for the 3.3v pin of an UNO, but my iPod (used as source in my project, providing regulated 3.3v) provides even more.

The 3.3V supply from an Arduino is (for some boards) rated at 50mA absolute max.   On connecting the load it will try to draw much more current briefly to charge the decoupling capacitors, which could cause problems?

The standard configuration of a 328 for Arduino is with brown-out threshold set to 2.7V, which is a little too close to 3.3V for comfort - perhaps the brownout detector is kicking in before the 3.3V supply has stabillised?

It is essential that AVcc and Vcc are within 0.3V of each other, BTW, someone's already hinted at this.

If you run at 3.3V you must ensure that no pin goes above 3.6V or below -0.3V at any time.
[ I won't respond to messages, use the forum please ]

Udo Klein

Double check if your power supply is really delivering 3.3V to the chip. Measure at the chip.

If there are 3.3V and it still doesn't work, maybe you should drop the frequency further. If you setup would be fine with a lower frequency then this would be a solution. The point is that lower frequency implies lower admissible voltage for stable operation.
Check out my experiments http://blog.blinkenlight.net


Oct 03, 2011, 07:08 pm Last Edit: Oct 03, 2011, 07:16 pm by flok3r Reason: 1
First of all: Thanks for all your great advices, they help me understand the mcu-world a bit more!
I can't exactly determine the mistake i made, but after re-organizing the breadboard components and changing some cable it somehow worked suddenly, so probably a lack of electrical connection somewhere, which is weird, because I had already removed / moved some stuff in order to minimize testing configuration and localize the mistake.
Though not everything works perfectly now ("fake" gnd and vc on analog pins have only 2.7v), it works!
Since I am really very new to all this, it also could have been a decoupling mistake.
Thanks, solved!

Go Up