Pages: [1]   Go Down
Author Topic: Ubuntu 11.04 64bit error opening serial port  (Read 1196 times)
0 Members and 1 Guest are viewing this topic.
Baltic states
Offline Offline
Jr. Member
**
Karma: 0
Posts: 97
new day, new try
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello everybody,
Since a couple of days ago I can't upload my codes to arduino. On my Ubuntu OS. Comes this message: http://i56.tinypic.com/x4hcb6.jpg
Before it worked perfectly. I have also win7 64bit on the same pc, in win7 Arduino Ide works well, but not in ubuntu. Maybe somebody has a solution for this problem?
Thanks!
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 139
Posts: 5860
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Go to your /dev/ directory and see if you have a "ttyACM0" file. If not, try rebooting the computer with the Ardunino connected. Check again.

Logged

Baltic states
Offline Offline
Jr. Member
**
Karma: 0
Posts: 97
new day, new try
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for your replay! Yes I have the "ttyACM0" file in /dev/ directory. And I have restarted the computer with connected Arduino. But it still doesn't work.
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 139
Posts: 5860
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try pressing the reset button on the Arduino, and release it just as the IDE says it is finished compiling and about to start the upload to the Arduino. The timing is a bit tricky sometimes.

At one point, I had to use a Windows version IDE to upload the "blink" example to get rid of the malfunctioning code in the Arduino.
Logged

Baltic states
Offline Offline
Jr. Member
**
Karma: 0
Posts: 97
new day, new try
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No chance..smiley-sad I have tried before to upload the blink code to arduino from win7 it was ok. And than I have I have tried to repeat the operation in ubuntu, but the same problem comes again.. One more interesting thing: When Arduino is connected to computer and running code  for example servo back and forth all over the time. And when I start the Arduino IDE in ubuntu the arduino uno stops working for a second. You know the same if you start Serial Monitor the program of arduino uno will reset. So here it happens every time when I start Arduino Ide, or I open I new window. Before it wasn`t so. It seems I must go back to windows:) I think it is something with ubuntu updates.. 
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 139
Posts: 5860
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Then it may be a bug in that version. Linux has its share of them.

Take a look at this thread. Each version has its own bugs. This user had a version that the delay() function failed. My repository version would not compile "Serial.begin(9600);". After the upgrade, all is great. Reply #5 covers the bug and fix.
http://arduino.cc/forum/index.php/topic,71182.0.html

These are the "signature errors" for these avr-libc versions:
1.6.8 - Serial.begin(9600) causes a crash.
1.7.0 - delay(1000) causes a crash.
1.7.1 - compiler "no declaration for fabs and ceil" error (prior to editing delay.h as described in the thread link above).
« Last Edit: October 09, 2011, 07:33:31 am by SurferTim » Logged

Pages: [1]   Go Up
Jump to: