Go Down

Topic: Mi HD44780 no me funciona, necesito ayuda.[Solucionsdo] (Read 1 time) previous topic - next topic

velon

Oct 12, 2011, 08:24 pm Last Edit: Oct 23, 2011, 01:15 pm by velon Reason: 1
Hola amigos, de nuevo por aquí.

Dispongo de un LCD 4x20 Optrex, DMC20481 NY-LY -AGE.

Llevo como tres meses intentando poner en servicio este display y confieso
que me lleva de cabeza. He realizado distintos montajes, he probado
bastantes circuitos electrónicos y un sinfín de bocetos con Arduino y no
consigo que muestre ningún carácter.

He llegado a pensar que debe estar mal alguna de las patillas de entrada ya que,
sólo logro que se encienda la luz de fondo y se llega a intuir las celdas de las 4
líneas de dígitos, pero nada más.

La pregunta es: Me pueden ayudar a ponerlo en servicio, sería de agradecer
si hay algún "truco" para ponerlo en marcha o decidir si he de adquirir
un nuevo.

Gracias.

Sergegsx

hombre si has probado un sin fin de montajes y de codigos, creo que lo mejor que puedes hacer es comprar otro. con un poco de suerte alguien te puede dar un codigo y un esquema de conexionado que te funcione pero vamos si de verdad has probado tanto (3 meses) es dificil que funcione.
yo las lcds las compro con la controladora incluida, de ese modo puedo comunicarme con ellas por I2C o serial y hace que el montaje sea de tan solo 2 cables de datos + positivo y negativo.
suerte

SrDonGato

con la libreria de ejemplo te tiene que funcionar, quizas no veas nada porque no tengas conectado el potenciometro que hace falta para el contraste.

pon que montaje tienes hecho.

un saludo

fm

Lo más probable es que te esté sucediendo lo que dice "SrDonGato", que no hayas conectado el "potenciometro" o divisor de tensión para controlar el contraste.

Aquí tienes una guía completa para que puedas arrancar el display:
http://www.ladyada.net/learn/lcd/charlcd.html

Hombre si te has tirado 3 meses y lo has "jeringado" mucho, es muy posible que durante la manipulación te lo hayas cargado. Espero que la guía paso a paso te sea de ayuda.

Un saludo
   

velon

Gracias por vuestras opiniones, todas son tenidas en cuenta.

Si, me cuesta entender lo que le pase al LCD. Quiero pensar que el LCD está bien y el problema es de mi parte, dado que jamás utilicé uno de estos y tal vez no estoy haciendo algo como es debido, todo es posible.

En cuanto al potenciómetro para la luz de fondo, sí lo he puesto, creo recordar que puse uno de 10K para reducir el consumo a niveles tolerables y también probé con otros valores, con el de 10K, consigo distinguir los cuadros de los dígitos que forman las cuatro líneas y los 20 dígitos de cada una.

He encontrado un enlace: http://arduino.cc/forum/index.php/topic,73655.0.html
Igual me ayuda a poner en marcha este dichoso LCD.

Ya os tengo informados.

Saludos.

lordcpu

#5
Oct 12, 2011, 10:31 pm Last Edit: Oct 12, 2011, 10:39 pm by lordcpu Reason: 1
Aca tienes el datasheet de la pantalla:

http://www.optrex.com/SiteImages/PartList/SPEC/DMC-20481NY-LY-BJE-BMN.pdf

La asignacion de pines es la estandar por lo que el programa de ejemplo "hola mundo" que viene con Arduino te sirve perfectamente:

http://arduino.cc/en/Tutorial/LiquidCrystal

Los pines 15 y 16 son opcionales y son para hacer encender la retroliluminacion de fondo de la pantalla la cual funciona con 4.4 volts, si lo vas a alimentar con los 5 volts del Arduino te recomiendo que uses un diodo rectificador en serie para que el voltaje baje 0.6 volts

Espero haberte ayudado

Saludos
Luis

fm

#6
Oct 13, 2011, 01:18 am Last Edit: Oct 13, 2011, 01:23 am by fm Reason: 1
No confundas la iluminación con el contraste. A qué tienes conectado el pin VEE del LCD - suele ser el pin 3-?
Lee el enlace que te he puesto antes que mejor tutorial no vas a encontrar. Saludos.
   

velon

#7
Oct 13, 2011, 11:35 pm Last Edit: Oct 13, 2011, 11:37 pm by velon Reason: 1
Gracias a todos por el interés demostrado. Si amigo fm, tienes toda la razón, esto me ocurrió al principio, confundí la luz de fondo por el contraste (aunque más arriba he comentado la luz de fondo como tal) y el contraste también me daba problemas, ya que tengo que poner el valor del pot. al mínimo cerca de masa, para que las celdas tengan algo de contraste). 

He hecho bastantes pruebas esta semana, si no me equivoco son 8 bocetos distintos, desde el "Hola Mundo", relojes, pulsadores, etc. y todos con el mismo resultado, no muestra ningún carácter. Mi hijo, me comenta que a el, le costó mucho hace dos años conseguir poner algunos caracteres en la primera línea pero en la dos, tres y cuatro dice que no pudo (a ver si fue el quien la guiñó).

Gracias a lordcpu y SrDonGato, por vuestra dedicación.

Como me está dando tantos quebraderos de cabeza, hoy me he decidido y he pedido uno muevo (mi hijo me decía que mejor uno para gráficos) ya que el precio no ofrece dudas 20x4 por 10 Euros puesto en casa.


Espero recibirlo entre mañana y el lunes (esto del finde...). Ya os tengo informados.

Saludos y buen finde

velon

Hola, es sabado tarde y no he recibido el nuevo LCD, espero que llegue el lunes.

Mi nuevo aporte a este tema viene suscitado por un comentario que he encontrado en un foro, por si alguien quiere visitarlo más abajo os dejo el enlace. Como se puede ver, el dichoso LCD en cuestión (no se si es también con el de Optrex, sospecho que sí), al parecer el contraste ha de ser controlado desde una tensión negativa, deduzco que este es el motivo por el que yo no podía regular el contraste sólo un poco muy cerca de 0V podía ver las celdas, como ya comenté más arriba.

Aquí el enlace: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1242852407/8 

Saludos y el lunes intentaré ver que ocurre con el nuevo LCD.

fm

   

velon

Hola de nuevo a todos.   

El martes me llegó el nuevo LCD, es el modelo B2004A1 compatible con el estándar HD44780.
La cuestión es que cuando lo he conectado al circuito de pruebas que tenía, ha funcionado a la primera, si bien es cierto que, sigo pensando que para lograr algo de contraste, debería poner una tensión negativa para que se pueda ajustar.

Para generar una tensión negativa hay muchas maneras, pero ya que estoy en pruebas, he pensado que si aprovecho la frecuencia de salida de un pin puesto a propósito y aplicando una rectificación adecuada y un par de condensadores, tal vez sea suficiente para el ajuste del contraste. ¿Que os parece la idea?

Espero vuestras respuestas. Gracias.

Cheyenne

A mí la idea en su concepción me parece buena pero dale la vuelta al condensador de 22 uF  :)

En la práctica no estoy seguro de que ese circuito tal cual puedas ponerlo. Le va a exigir a la salida de Arduino unos picos de intensidad que no estoy seguro si podrá aguantarlos, piensa que en el momento de conexión a 5 V en la salida de Arduino no hay nada que limite la intensidad para la carga del condensador. No estoy seguro pero creo que debe de haber elementos discretos que te den una tensión negativa de poco importe para pequeñas intensidades. Eso sí, si no haces más pedido te costarán más los portes.

Sigo pensando en algún circuito sencillo pero ahora tengo la cabeza en blanco.
http://cuadricopterodiyarduino.blogspot.com/

Cheyenne

Nada, lo más sencillo que yo veo es que ataques tu esquema a través de dos transistores, PNP y NPN para que sean ellos los que suministren la corriente. El emisor del PNP a Vcc, el colector unido al emisor del NPN y a la entrada de tu etapa (al condensador), el emisor del NPN a tierra. Y la salida de Arduino  a las bases con sus correspondientes resistencias.
http://cuadricopterodiyarduino.blogspot.com/

fm

Me tiene muy rallado tu sétup y los displays. He visto los datasheets del fabricante y no veo nada que apunte hacia suministrar una tensión negativa. Podrías hacer una foto del potenciometro y como lo tienes conectado? Me resulta muy extraño lo que te esta sucediendo.
   

velon

#14
Oct 21, 2011, 05:39 pm Last Edit: Oct 21, 2011, 05:43 pm by velon Reason: 1
Disculpad por la tardanza, he estado bastante ocupado y no puede atender como quisiera este tema.

Por supuesto "fm", adjunto una foto del montaje y aunque no está muy claro, se trata de una de las dos primeras fotos que hice al nuevo LCD, se aprecia la pegatina protectora en la pantalla sin despegar  :), respecto al potenciómetro, está entre +V y gnd y el eje (en amarillo), conectado al pin 3 de la pantalla.

También se aprecia en la foto que, el pin 15 (luz de fondo, nada que ver con el contraste) está igualmente conectado al eje del pot. Posteriormente lo he conectado al cátodo del diodo que se puede ver en la foto.

En principio, todo parece estar en su sitio y condiciones, salvo que tengáis alguno, opinión en contra, en cuyo caso me lo indicáis y rectifico. Voy a seguir intentando mejorar el tema del contraste y si logro algún avance ya os lo comunico.

Respecto del la posición de los condensadores, sí ambos están invertidos, pasé la imagen tal cual la saqué del pdf. Supongo que los efectos que mencionas "Cheyenne", intentaré minimizarlos de algún modo, ya te cuento.

La próxima semana voy a estar de viaje y no se si podré ponerme en contacto y más aún, no podré hacer práctica alguna, vaya, pero las prioridades son las que son.

Saludos y gracias por vuestro tiempo.

Go Up