Go Down

Topic: Pb detection montage standalone (Read 1 time) previous topic - next topic

klgui4

Bonjour,

Je viens de finir de monter un arduino en standalone, je l'ai raccordé par le biais d'un adaptateur usb to ttl visible sur ce post : http://arduino.cc/forum/index.php/topic,74869.0.html
Cependant mon mac ne le reconnait pas, j'essayé des drivers pour pl2303 trouvés sur sourceforge mais pas d'amélioration.. Quelqu'un m'avait conseillé le site prolific mais il a l'air down.. Comment puis-je faire ?

Merci beaucoup !

skywodd

Bonjour,

Sous linux & unix like (est ce que mac rentre dans le lot je sais pas) les drivers pour les CI pl2303 sont reconnu en natif mais pas chargé au démarrage.
Sous linux j'utilise cette commande, est t-elle valide sous mac je ne sais pas:
Code: [Select]
modprobe pl2303
ou
Code: [Select]
insmod pl2303

Sinon sur google il semblerai qu'il y est déja pas mal de post sur ce sujet dont celui ci :
http://xbsd.nl/2011/07/pl2303-serial-usb-on-osx-lion.html
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

al1fch

#2
Oct 15, 2011, 07:44 pm Last Edit: Oct 15, 2011, 07:47 pm by al1fch Reason: 1
L'adaptateur Trendnet TU-S9 (RS232/USB) utilise un PL2303 (je viens de vérifier sur le CD)
Les drivers sont disponibles sur le site Trendnet (-> Telechargement)
http://www.trendnet.com/langfr/products/proddetail.asp?prod=150_TU-S9&cat=49
C'est peut être pas la dernière version mais en attendant que le site Prolific soit remis en service ...

fdufnews

L'atMega est déjà programmé avec le bootloader?

klgui4

Je l'ai acheté sur Adafruit et il mentionne que oui, et pourtant même sur mon pc Windows (qui lui détecte bien l'adaptateur) l'upload est impossible :/

al1fch

Peux-tu donner le schéma complet du standalone et de ses liaisons avec le module UC00B ?

Quelques petites précisions (peut être superflues)  :
-Les mega328 d'Adafruit sont fournis avec le bootloader des cartes Duemilanove. (un poil modifié)
Il faut donc configurer l'IDE Arduino en Duemilanove
-selon que ton 'satndalone' est en 5V ou en 3,3V il faut positionner le petit cavalier des adaptateurs Cytron UC00B en 5V ou en 3,3V
-le démarrage automatique du bootloader est possible avec cet adapteur par le biais de sa sortie DTR si côté 'standalone' tu as reproduis tout le circuit de reset des Arduino avec le condensateur de 100nF entre DTR et broche Reset du µC
-sans ce câblage d'autoreset il faut un bouton poussoir de Reset sur le µC et faire une pression brêve au moment ou Avrdude est lancé : annonce "Binary sketch size..."

klgui4

Pour le cavalier je pense que de ce côté pas de soucis, je l'ai placé sur le 5V.

Quant à la pin DTR je ne l'ai pas raccordé pour le moment, j'utilise donc un pushbutton pour le reset.

Voici la photo du montage :



Je peux bien entendu vous faire un schéma par le biais de fritzing si vous le souhaiter. La photo n'est là que pour être plus rapide.

(Pour le moment je ne sais pas encore si mon mac détecte mon adaptateur, contrairement à mon Pc sous 7).

al1fch

La photo en dit autant, sinon plus que le 'Fritzing' , et en plus c'est plus rapide !!

J'ai plusieurs doutes :
-je crois voir des liaisons Rx-Rx(fil jaune)  et Tx-Tx (fil orange) au lieu du croisement nécessaire le Tx de l'un (sortie) doit aller au Rx de l'autre (entrée)
-où vont les fils noir et rouges ?( Quand le câble USB est branché c'est l'adaptateur qui alimente en 5V le montage)
-les VCC du haut et du bas sont ils reliés ? idem pour les 0V du haut et du bas ...
-les Vcc et 0V de l'adaptateur sont ils reliés au reste du montage ?

 

klgui4

#8
Oct 16, 2011, 10:33 pm Last Edit: Oct 16, 2011, 10:36 pm by klgui4 Reason: 1
Effectivement j'avais branché TX sur TX et RX sur RX car l'inverse ne marchait pas non plus au départ ^^

Les fils rouge et noir de l'adaptateur vont vers les rangés + et - de la breadbord, j'ai raccordé les  rangés + et - de la breadbord ;)

Go Up