Go Down

Topic: ardulab y arduino (Read 3 times) previous topic - next topic

carlesdolomiti

^_^Hola . Realice una compra de un arduino uno en bricogeek . Todo va de maravillas. Lo que no puedo es que Ardulab me lo reconozca . ¿Puede ser que esta plataforma todavía no reconozca el firmenware de este arduino? .¿ Hay otra plataforma de laboratorio virtual gratuita que si lo haga?.
Gracias

josemanu

¿Has instalado el driver correcto? mira que mucha gente instala el driver FTDI y la uno necesita el driver arduinoUNO.ini

Ardulab debe reconocer la placa automáticamente y cargar el firmware en ella. Primero prueba con el Arduino IDE, si te la reconoce sin problemas Ardulab también la tiene que reconocer.
http://www.ardumania.es/

Iniciación

carlesdolomiti

Hola. En el firmenware 0022. ¿ donde está el archivo uno.ini?. porque no lo veo. Gracias
Carlos

josemanu

Carpeta drivers, archivo ArduinoUNO.inf. No en el subdirectorio FTDI USB Drivers
http://www.ardumania.es/

Iniciación

carlesdolomiti

ok. encontrado y actualizado , también he sacado el ftdi. Lo malo que ardulab 004 no lo reconoce. encuentra el puerto y nada . y si le digo programar firmenware dice que no hay dispositivo conectado en ese puerto. Gracias por lo del uno.ini.
Carlos

carlesdolomiti

Al final lo he conectado con ardulab. Lo que he realizado es cargar el firmenware ( ardulab-firmenware 004 ), que trae ardulab en pde directamente al arduino uno con el cargador y ya se conecta bien.
Un saludo

chiva

Hace un par de días estuve probando el ArduLab y efectivamente el cargador de firmware no va muy fino, también tuve que meterlo con el IDE
Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

josemanu

Es decir: que no me pasa a mi solo.

En las pruebas iniciales lo achacamos a mi sistema güindous, es es un poco del palo, con otros funcionaba  bien el cargador automático.

Realmente no es un problema grabe tener que cargar a mano el .pde, yo trabajo con Ardulab así.

http://www.ardumania.es/

Iniciación

poliveira1978

No Windows 7 - 64bits só funciona se arrancar como Administrador.

Alex asturias

pues para mas inri en el nuevo entorno 1.0 no es posible cargar el firmware a mano por que dice que la instruccion byte ya no es soportada y que se use otra en su lugar... asiq por el momento en el ide 1.0 es imposible instalarlo hasta que actualicen el codigo del ardulab 004 que ya toca...

chiva

Pues usa las funciones que te recomienda:

Serial.print(xxxx,BYTE); >>>> Serial.write(xxxx);
Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

Alex asturias

si chiva pero habrá mucha gente que no sepa hacerlo o no entienda el mensaje y por ello no pueda usar el ardulab o bien piense que es un fallo o lo que sea creo que seria lógico que el desarrollador del ardulab modificase el código para el nuevo ide 1.0 que le llevara 5 min y así en las próximas descargas desde su web ya estará corregido(es mi opinión).

un saludo

josemanu

Y tienes razón Alex, el desarrollador debería hacerlo. Pero resulta que está agobiadísimo de faena entre unas cosas y otras, así que aquí es donde la comunidad podemos poner nuestro granito de arena.

Si modificas el .pde que viene con Ardulab para poder ser cargado con el IDE 1.0 te agradecería que lo colgaras aquí en el foro, así más gente puede encontrar la solución hasta que Eduardo (el desarrollador) pueda hacer las modificaciones oportunas.

En cuanto pueda yo también me pongo a ello. De momento se lo notifico a Eduardo.

Un saludo.
http://www.ardumania.es/

Iniciación

Alex asturias

Sinceramente decidí lo fácil x no complicarme descargue el ide 0023 y desde el si deja y lo subí a la placa

josemanu

OK, no problem ;)

Como somos voluntarios no podemos exigirnos nada unos a otros.

De todos modos tu aporte es valioso. Me comunico con Eduardo y me pongo a ello en cuanto pueda.

Un saludo.
http://www.ardumania.es/

Iniciación

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview